aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python
diff options
context:
space:
mode:
authorAndrei Gherzan <andrei@gherzan.ro>2012-04-05 23:54:25 +0300
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-04-25 00:02:28 +0100
commita92847ed7671386225c0738d62780a9f1b043789 (patch)
treee5cfa841d2a7f128944d65a62ae9c8e092abbae9 /meta/recipes-devtools/python/python
parent3f1be431054b3947bee9a2503eea1a3cefb38f4c (diff)
downloadopenembedded-core-contrib-a92847ed7671386225c0738d62780a9f1b043789.tar.gz
python: Add patch to avoid warning about sunaudiodev module
sunaudiodev module is sunos specific so we avoid a warning by not. adding this module to missing variable. [YOCTO #1937] Signed-off-by: Andrei Gherzan <andrei@gherzan.ro> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/python/python')
-rw-r--r--meta/recipes-devtools/python/python/avoid_warning_for_sunos_specific_module.patch23
1 files changed, 23 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python/avoid_warning_for_sunos_specific_module.patch b/meta/recipes-devtools/python/python/avoid_warning_for_sunos_specific_module.patch
new file mode 100644
index 0000000000..337e0e3e29
--- /dev/null
+++ b/meta/recipes-devtools/python/python/avoid_warning_for_sunos_specific_module.patch
@@ -0,0 +1,23 @@
+sunaudiodev module is sunos specific so we avoid a warning by not
+adding this module to missing variable.
+
+Upstream-Status: Inappropriate [distribution]
+
+Signed-off-by: Andrei Gherzan <andrei@gherzan.ro>
+
+Index: Python-2.7.2/setup.py
+===================================================================
+--- Python-2.7.2.orig/setup.py 2012-04-05 22:29:18.049196608 +0300
++++ Python-2.7.2/setup.py 2012-04-05 22:29:57.505195453 +0300
+@@ -1522,8 +1522,9 @@
+ if platform == 'sunos5':
+ # SunOS specific modules
+ exts.append( Extension('sunaudiodev', ['sunaudiodev.c']) )
+- else:
+- missing.append('sunaudiodev')
++ # If platform is not sunos warning is useless
++ #else:
++ # missing.append('sunaudiodev')
+
+ if platform == 'darwin':
+ # _scproxy