aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python
diff options
context:
space:
mode:
authorSaul Wold <sgw@linux.intel.com>2011-09-29 08:54:04 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-09-29 16:57:23 +0100
commit9f9612d15acc6ee3b71f52bdb3f1ec4cb56b1a17 (patch)
treea3780e01d88dbfce644bd63658dd231cec909bf3 /meta/recipes-devtools/python/python
parent9c9ea24b115a9bb87df1323b5f185ce426262aec (diff)
downloadopenembedded-core-contrib-9f9612d15acc6ee3b71f52bdb3f1ec4cb56b1a17.tar.gz
python: fix sqlite RPATH issue
Signed-off-by: Saul Wold <sgw@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/python/python')
-rw-r--r--meta/recipes-devtools/python/python/remove_sqlite_rpath.patch19
1 files changed, 19 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python/remove_sqlite_rpath.patch b/meta/recipes-devtools/python/python/remove_sqlite_rpath.patch
new file mode 100644
index 0000000000..4ec627ea51
--- /dev/null
+++ b/meta/recipes-devtools/python/python/remove_sqlite_rpath.patch
@@ -0,0 +1,19 @@
+This patch removes the RPATH setting which contains a pointer to
+the target relocated sysroot, which is incorrect.
+
+Upstream-Status: Inappropriate [Embedded Specific]
+
+Signed-off-by: Saul Wold <sgw@linux.intel.com>
+
+Index: Python-2.6.6/setup.py
+===================================================================
+--- Python-2.6.6.orig/setup.py 2011-09-28 14:22:57.000000000 -0700
++++ Python-2.6.6/setup.py 2011-09-28 16:11:25.147279633 -0700
+@@ -1079,7 +1079,6 @@
+ include_dirs=["Modules/_sqlite",
+ sqlite_incdir],
+ library_dirs=sqlite_libdir,
+- runtime_library_dirs=sqlite_libdir,
+ extra_link_args=sqlite_extra_link_args,
+ libraries=["sqlite3",]))
+ else: