aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2013-06-13 02:28:28 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-06-14 12:43:20 +0100
commit5745a482a85c064a1eec960aff104cf8ce588e30 (patch)
treef80c75b2f6425a0c64e73b52b4b8211a48b9a99d /meta/recipes-devtools/python/python
parentd9f840725f3ea67fbd28d0903c99b729df5b1377 (diff)
downloadopenembedded-core-contrib-5745a482a85c064a1eec960aff104cf8ce588e30.tar.gz
python: -Wformat is needed by gcc 4.8
This fixes errors in packages using python( build with gcc 4.8) | /home/jenkins/oe/shr-core-branches/shr-core/tmp-eglibc/sysroots/qemuarm/usr/include/python2.7/modsupport.h:27:1: error: 'PyArg_ParseTuple' is an unrecognized format function type [-Werror=format=] | PyAPI_FUNC(int) PyArg_ParseTuple(PyObject *, const char *, ...) Py_FORMAT_PARSETUPLE(PyArg_ParseTuple, 2, 3); | ^ | cc1: all warnings being treated as errors | cc1: all warnings being treated as errors Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/python/python')
-rw-r--r--meta/recipes-devtools/python/python/gcc-4.8-fix-configure-Wformat.patch20
1 files changed, 20 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python/gcc-4.8-fix-configure-Wformat.patch b/meta/recipes-devtools/python/python/gcc-4.8-fix-configure-Wformat.patch
new file mode 100644
index 0000000000..b5d9d5d424
--- /dev/null
+++ b/meta/recipes-devtools/python/python/gcc-4.8-fix-configure-Wformat.patch
@@ -0,0 +1,20 @@
+backport bug 17547 from http://hg.python.org/cpython/rev/9d50af4c482f/
+
+-Wformat is needed by gcc 4.8
+
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+
+Upstream-Status: Backport
+Index: Python-2.7.3/configure.in
+===================================================================
+--- Python-2.7.3.orig/configure.in 2013-06-11 02:22:04.186529212 -0700
++++ Python-2.7.3/configure.in 2013-06-13 02:17:06.324403327 -0700
+@@ -1196,7 +1196,7 @@
+ then
+ AC_MSG_CHECKING(whether gcc supports ParseTuple __format__)
+ save_CFLAGS=$CFLAGS
+- CFLAGS="$CFLAGS -Werror"
++ CFLAGS="$CFLAGS -Werror -Wformat"
+ AC_COMPILE_IFELSE([
+ AC_LANG_PROGRAM([[void f(char*,...)__attribute((format(PyArg_ParseTuple, 1, 2)));]], [[]])
+ ],[