aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python
diff options
context:
space:
mode:
authorKoen Kooi <koen@dominion.thruhere.net>2018-04-16 15:00:21 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-05-04 09:54:57 +0100
commitc61c416a6504f7e8885df3c94c839d1031920a1c (patch)
tree0b7018d65c128319c2feebb11e70d68b1628ed1f /meta/recipes-devtools/python/python
parent6427bcae42fb9ec05ccfd5b63db6bc3ee2afcd4f (diff)
downloadopenembedded-core-contrib-c61c416a6504f7e8885df3c94c839d1031920a1c.tar.gz
python 2.7: fix multilib patch to accept multiarch style paths
Using 'basename' to strip the prefix fails when using multiarch style paths. Signed-off-by: Koen Kooi <koen.kooi@linaro.org> Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta/recipes-devtools/python/python')
-rw-r--r--meta/recipes-devtools/python/python/multilib.patch2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta/recipes-devtools/python/python/multilib.patch b/meta/recipes-devtools/python/python/multilib.patch
index 1116dd518e..d24bc15f01 100644
--- a/meta/recipes-devtools/python/python/multilib.patch
+++ b/meta/recipes-devtools/python/python/multilib.patch
@@ -11,7 +11,7 @@ Index: Python-2.7.14/configure.ac
+AC_SUBST(LIB)
+AC_MSG_CHECKING(LIB)
-+LIB=`basename ${libdir}`
++LIB="SEDMELIBLEAF"
+AC_MSG_RESULT($LIB)
AC_SUBST(LIBRARY)