summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python3_3.7.3.bb
diff options
context:
space:
mode:
authorJoshua Watt <jpewhacker@gmail.com>2019-06-20 10:43:02 -0500
committerRichard Purdie <richard.purdie@linuxfoundation.org>2019-06-21 00:33:23 +0100
commita5431f3b81ecc1095b4b916355d24ee0b0a307dd (patch)
treed5fc8ddae3893d7cb156270254f8dd6516b54b36 /meta/recipes-devtools/python/python3_3.7.3.bb
parentf384e39ad1ca1514fb7b5d7fa0d63e0c863761ca (diff)
downloadopenembedded-core-contrib-a5431f3b81ecc1095b4b916355d24ee0b0a307dd.tar.gz
python3: Disable PGO for reproducible builds
Enabling PGO for python current causes it to not be reproducible when building, so disable it for now. (From OE-Core rev: e53ebf297c86bba727e075c44c595beb061dbfc8) Signed-off-by: Joshua Watt <JPEWhacker@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/python/python3_3.7.3.bb')
-rw-r--r--meta/recipes-devtools/python/python3_3.7.3.bb10
1 files changed, 9 insertions, 1 deletions
diff --git a/meta/recipes-devtools/python/python3_3.7.3.bb b/meta/recipes-devtools/python/python3_3.7.3.bb
index 2444296142..8e77dbe959 100644
--- a/meta/recipes-devtools/python/python3_3.7.3.bb
+++ b/meta/recipes-devtools/python/python3_3.7.3.bb
@@ -75,8 +75,16 @@ CACHED_CONFIGUREVARS = " \
ac_cv_file__dev_ptc=no \
ac_cv_working_tzset=yes \
"
+python() {
+ # PGO currently causes builds to not be reproducible, so disable it for
+ # now. See YOCTO #13407
+ if bb.utils.contains('MACHINE_FEATURES', 'qemu-usermode', True, False, d) and d.getVar('BUILD_REPRODUCIBLE_BINARIES') != '1':
+ d.setVar('PACKAGECONFIG_PGO', 'pgo')
+ else:
+ d.setVar('PACKAGECONFIG_PGO', '')
+}
-PACKAGECONFIG_class-target ??= "readline ${@bb.utils.contains('MACHINE_FEATURES', 'qemu-usermode', 'pgo', '', d)}"
+PACKAGECONFIG_class-target ??= "readline ${PACKAGECONFIG_PGO}"
PACKAGECONFIG_class-native ??= "readline"
PACKAGECONFIG_class-nativesdk ??= "readline"
PACKAGECONFIG[readline] = ",,readline"