aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python3_3.5.6.bb
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@intel.com>2018-10-15 19:13:01 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-10-15 23:19:37 +0100
commitfe3727af217dce4488f1fc6aab3f66232cf11fea (patch)
treec8b4faa6178d556ecb1d67343982d44a857916f6 /meta/recipes-devtools/python/python3_3.5.6.bb
parentfc4c4f40dbcf558a48058d944eef21e588d64aa0 (diff)
downloadopenembedded-core-contrib-fe3727af217dce4488f1fc6aab3f66232cf11fea.tar.gz
python: don't wipe RDEPENDS when parsing manifest
We want to allow the main recipe to extend RDEPENDS directly, so don't wipe RDEPENDS when reading the manifest. This fixes the missing python-misc dependency from python-modules. As the wiping was having the good side-effect of removing the PN-dev dependency on PN (which doesn't exist), clear RDEPENDS_${PN}-dev. Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/python/python3_3.5.6.bb')
-rw-r--r--meta/recipes-devtools/python/python3_3.5.6.bb3
1 files changed, 2 insertions, 1 deletions
diff --git a/meta/recipes-devtools/python/python3_3.5.6.bb b/meta/recipes-devtools/python/python3_3.5.6.bb
index 372f27b15d..72478f8663 100644
--- a/meta/recipes-devtools/python/python3_3.5.6.bb
+++ b/meta/recipes-devtools/python/python3_3.5.6.bb
@@ -245,6 +245,8 @@ FILES_${PN}-man = "${datadir}/man"
RDEPENDS_${PN}-ptest = "${PN}-modules ${PN}-tests unzip bzip2"
+RDEPENDS_${PN}-dev = ""
+
BBCLASSEXTEND = "nativesdk"
RPROVIDES_${PN} += "${PN}-modules"
@@ -288,7 +290,6 @@ python(){
for value in python_manifest[key]['cached']:
d.appendVar('FILES_' + pypackage, ' ' + value)
- d.setVar('RDEPENDS_' + pypackage, '')
for value in python_manifest[key]['rdepends']:
# Make it work with or without $PN
if '${PN}' in value: