aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python3/tweak-MULTIARCH-for-powerpc-linux-musl.patch
diff options
context:
space:
mode:
authorAlexander Kanavin <alex.kanavin@gmail.com>2019-02-06 17:26:34 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2019-02-08 10:54:16 +0000
commit02714c105426b0d687620913c1a7401b386428b6 (patch)
tree4d42476c2708f71216ee5455b33447fe8485fb69 /meta/recipes-devtools/python/python3/tweak-MULTIARCH-for-powerpc-linux-musl.patch
parent59986a8c678cc7b5eb840323986bdc3513f76b55 (diff)
downloadopenembedded-core-contrib-02714c105426b0d687620913c1a7401b386428b6.tar.gz
python3: upgrade to 3.7.2
I took the same approach as the recent perl upgrade: write recipe from scratch, taking the pieces from the old recipe only when they were proven to be necessary. The pgo, manifest and ptest features are all preserved. New features: - native and target recipes are now unified into one recipe - check_build_completeness.py runs right after do_compile() and verifies that all optional modules have been built (a notorious source of regressions) - a new approach to sysconfig.py and distutils/sysconfig.py returning values appropriate for native or target builds: we copy the configuration file to a separate folder, add that folder to sys.path (through environment variable that differs between native and target builds), and point python to the file through another environment variable. There were a few other patches where it was difficult to decide if the patch is still relevant, and how to test that it works correctly; please add those as-needed by testing the new python. Signed-off-by: Alexander Kanavin <alex.kanavin@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/python/python3/tweak-MULTIARCH-for-powerpc-linux-musl.patch')
-rw-r--r--meta/recipes-devtools/python/python3/tweak-MULTIARCH-for-powerpc-linux-musl.patch40
1 files changed, 0 insertions, 40 deletions
diff --git a/meta/recipes-devtools/python/python3/tweak-MULTIARCH-for-powerpc-linux-musl.patch b/meta/recipes-devtools/python/python3/tweak-MULTIARCH-for-powerpc-linux-musl.patch
deleted file mode 100644
index 34c91755ff..0000000000
--- a/meta/recipes-devtools/python/python3/tweak-MULTIARCH-for-powerpc-linux-musl.patch
+++ /dev/null
@@ -1,40 +0,0 @@
-From 7362464383bbd54f8e6be4389f2c74c0717bc6e1 Mon Sep 17 00:00:00 2001
-From: Serhey Popovych <serhe.popovych@gmail.com>
-Date: Sat, 8 Dec 2018 11:24:06 -0500
-Subject: [PATCH] configure.ac: tweak MULTIARCH for powerpc-linux-musl
-
-For musl builds, the MULTIARCH is powerpc-linux-musl and configure.ac
-does not have lines to recognize it causing configure error for the
-platform triplet when building for powerpc 32bit.
-
-This is feature described in PEP-3149 and to prevent possible runtime
-compatibility issues we map powerpc-linux-musl to powerpc-linux-gnu.
-
-Look at similar change by Hongxu Jia <hongxu.jia@> presended in
-tweak-MULTIARCH-for-powerpc-linux-gnuspe.patch to handle p1022ds BSP
-builds.
-
-Upstream-Status: Pending
-Signed-off-by: Serhey Popovych <serhe.popovych@gmail.com>
----
- configure.ac | 4 ++++
- 1 file changed, 4 insertions(+)
-
-diff --git a/configure.ac b/configure.ac
-index 95c98d1..1a4d8aa 100644
---- a/configure.ac
-+++ b/configure.ac
-@@ -752,6 +752,10 @@ if test x$MULTIARCH = xpowerpc-linux-gnuspev1
- then
- MULTIARCH="powerpc-linux-gnuspe"
- fi
-+if test x$MULTIARCH = xpowerpc-linux-musl
-+then
-+ MULTIARCH="powerpc-linux-gnu"
-+fi
-
- AC_SUBST(MULTIARCH)
-
---
-2.7.4
-