aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python3/04-default-is-optimized.patch
diff options
context:
space:
mode:
authorAlejandro Hernandez <alejandro.hernandez@linux.intel.com>2015-02-27 12:49:22 -0600
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-05-05 22:14:19 +0100
commit45290ff4d1902bd0ab5377568f969fbb660c0c87 (patch)
tree1bab381b67f24b173b38a54cb599689fc9fe0f7a /meta/recipes-devtools/python/python3/04-default-is-optimized.patch
parent4563788a21fb1715920cd5056b43d85c69563c32 (diff)
downloadopenembedded-core-contrib-45290ff4d1902bd0ab5377568f969fbb660c0c87.tar.gz
python3: Upgrade from 3.3.3 to 3.4.2
Modifies: python3-native_3.3.3.bb -> python3-native_3.4.2.bb: Updates checksums, version, patches and SRC_URIs to use xz format, LICENSE did not change, dates were updated, adds fix for ctypes/libffi needed for pip <- required since Python 3.4 (see PEP #453). python3_3.3.3.bb -> python3_3.4.2.bb: Updates checksums, version, patches and SRC_URIs to use xz format, adds fix for ctypes/libffi, fixes oe_multilib_header() call, adds python3-core as RDEPENDS to python3-misc to avoid QA issue. generate-manifest-3.4.py - > generate-manifest-3.4.py: fixes reprlib, adds _sitebuiltins and _collections_abc <- formerly part of collections, separated since 3.4 python-3.3-manifest.inc -> python-3.4-manifest.inc Rebases: 12-distutils-prefix-is-inside-staging-area.patch python-3.3-multilib.patch 04-default-is-optimized.patch avoid-ncursesw-include-path.patch Deletes (fixed upstream): fix-ast.h-dependency.patch python3-fix-build-error-with-Readline-6.3.patch 06-ctypes-libffi-fix-configure.patch remove_sqlite_rpath.patch [YOCTO #6857] Signed-off-by: Alejandro Hernandez <alejandro.hernandez@linux.intel.com>
Diffstat (limited to 'meta/recipes-devtools/python/python3/04-default-is-optimized.patch')
-rw-r--r--meta/recipes-devtools/python/python3/04-default-is-optimized.patch39
1 files changed, 20 insertions, 19 deletions
diff --git a/meta/recipes-devtools/python/python3/04-default-is-optimized.patch b/meta/recipes-devtools/python/python3/04-default-is-optimized.patch
index d5afd40025..3b8f264a58 100644
--- a/meta/recipes-devtools/python/python3/04-default-is-optimized.patch
+++ b/meta/recipes-devtools/python/python3/04-default-is-optimized.patch
@@ -1,20 +1,21 @@
Upstream-Status: Inappropriate [embedded specific]
-Updated original patch for python 2.7.3
-
-Signed-Off-By: Nitin A Kamble <nitin.a.kamble@intel.com>
-2012/05/01
-
-
# when compiling for an embedded system, we need every bit of
# performance we can get. default to optimized with the option
# of opt-out.
# Signed-Off: Michael 'Mickey' Lauer <mickey@vanille-media.de>
-Index: Python-3.2.3/Python/compile.c
+
+2012/05/01
+Signed-Off-By: Nitin A Kamble <nitin.a.kamble@intel.com>
+
+Rebased for 3.4.2 02/2015
+Signed-off-by: Alejandro Hernandez <alejandro.hernandez@linux.intel.com>
+
+Index: Python-3.4.2/Python/compile.c
===================================================================
---- Python-3.2.3.orig/Python/compile.c 2012-04-10 23:54:08.000000000 -0700
-+++ Python-3.2.3/Python/compile.c 2012-09-19 15:58:46.649123998 -0700
+--- Python-3.4.2.orig/Python/compile.c
++++ Python-3.4.2/Python/compile.c
@@ -30,7 +30,7 @@
#include "symtable.h"
#include "opcode.h"
@@ -24,28 +25,28 @@ Index: Python-3.2.3/Python/compile.c
#define DEFAULT_BLOCK_SIZE 16
#define DEFAULT_BLOCKS 8
-Index: Python-3.2.3/Modules/main.c
+Index: Python-3.4.2/Modules/main.c
===================================================================
---- Python-3.2.3.orig/Modules/main.c 2012-04-10 23:54:07.000000000 -0700
-+++ Python-3.2.3/Modules/main.c 2012-09-19 16:00:32.153124053 -0700
-@@ -46,7 +46,7 @@
+--- Python-3.4.2.orig/Modules/main.c
++++ Python-3.4.2/Modules/main.c
+@@ -38,7 +38,7 @@ static wchar_t **orig_argv;
static int orig_argc;
/* command line options */
--#define BASE_OPTS L"bBc:dEhiJm:OqRsStuvVW:xX:?"
-+#define BASE_OPTS L"bBc:dEhiJm:NOqRsStuvVW:xX:?"
+-#define BASE_OPTS L"bBc:dEhiIJm:OqRsStuvVW:xX:?"
++#define BASE_OPTS L"bBc:dEhiIJm:NOqRsStuvVW:xX:?"
#define PROGRAM_OPTS BASE_OPTS
-@@ -71,6 +71,7 @@
+@@ -64,6 +64,7 @@ static char *usage_2 = "\
-m mod : run library module as a script (terminates option list)\n\
-O : optimize generated bytecode slightly; also PYTHONOPTIMIZE=x\n\
-OO : remove doc-strings in addition to the -O optimizations\n\
+-N : do NOT optimize generated bytecode\n\
-q : don't print version and copyright messages on interactive startup\n\
- -R : use a pseudo-random salt to make hash() values of various types be\n\
- unpredictable between separate invocations of the interpreter, as\n\
-@@ -407,8 +408,8 @@
+ -s : don't add user site directory to sys.path; also PYTHONNOUSERSITE\n\
+ -S : don't imply 'import site' on initialization\n\
+@@ -418,8 +419,8 @@ Py_Main(int argc, wchar_t **argv)
/* case 'J': reserved for Jython */