summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python3-wheel_0.37.1.bb
diff options
context:
space:
mode:
authorRoss Burton <ross@burtonini.com>2022-03-08 16:32:02 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2022-03-09 11:46:23 +0000
commite2c7501645eec12d3168b6e8606549ce3e5f8db2 (patch)
tree87f1d42614b9145ea264c6508e6826083a6a4832 /meta/recipes-devtools/python/python3-wheel_0.37.1.bb
parentc0a24279c740555a06a5c57e2a01ca7b20f8e668 (diff)
downloadopenembedded-core-contrib-e2c7501645eec12d3168b6e8606549ce3e5f8db2.tar.gz
python3-wheel: clean up PYPA_WHEEL usage
Remove the use of PYPA_WHEEL in the native do_install() as this variable will be disappearing shortly. Remove the bbfatal_log in the native do_install(), if this breaks then something has gone very wrong and the user is not expected to fix it. Also flit_core inherits setuptools3-base, so no need to inherit it again. Signed-off-by: Ross Burton <ross.burton@arm.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/python/python3-wheel_0.37.1.bb')
-rw-r--r--meta/recipes-devtools/python/python3-wheel_0.37.1.bb7
1 files changed, 2 insertions, 5 deletions
diff --git a/meta/recipes-devtools/python/python3-wheel_0.37.1.bb b/meta/recipes-devtools/python/python3-wheel_0.37.1.bb
index 91bff82509..83a7c986a8 100644
--- a/meta/recipes-devtools/python/python3-wheel_0.37.1.bb
+++ b/meta/recipes-devtools/python/python3-wheel_0.37.1.bb
@@ -6,7 +6,7 @@ LIC_FILES_CHKSUM = "file://PKG-INFO;beginline=10;endline=10;md5=8227180126797a01
SRC_URI[sha256sum] = "e9a504e793efbca1b8e0e9cb979a249cf4a0a7b5b8c9e8b65a5e39d49529c1c4"
-inherit flit_core pypi setuptools3-base
+inherit flit_core pypi
SRC_URI += " file://0001-Backport-pyproject.toml-from-flit-backend-branch.patch"
@@ -15,9 +15,7 @@ DEPENDS:remove:class-native = "python3-pip-native"
do_install:class-native () {
# We need to bootstrap python3-wheel-native
install -d ${D}${PYTHON_SITEPACKAGES_DIR}
- PYPA_WHEEL="${B}/dist/${PYPI_PACKAGE}-${PV}-*.whl"
- unzip -d ${D}${PYTHON_SITEPACKAGES_DIR} ${PYPA_WHEEL} || \
- bbfatal_log "Failed to install"
+ unzip -d ${D}${PYTHON_SITEPACKAGES_DIR} ${PIP_INSTALL_DIST_PATH}/*.whl
# pip install would normally generate [project.scripts] in ${bindir}
install -d ${D}/${bindir}
@@ -37,4 +35,3 @@ EOF
}
BBCLASSEXTEND = "native nativesdk"
-