summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python3-wheel_0.37.1.bb
diff options
context:
space:
mode:
authorTim Orling <ticotimo@gmail.com>2022-02-22 11:16:30 -0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2022-02-25 15:06:46 +0000
commit764d0c2e079b3511afe03deadf3ec922e41b89aa (patch)
treeb1432c3f744f3bef32b6a3401bc5e80346490e66 /meta/recipes-devtools/python/python3-wheel_0.37.1.bb
parentf0292098dc5afc62e0cd91d475edeb1784700795 (diff)
downloadopenembedded-core-contrib-764d0c2e079b3511afe03deadf3ec922e41b89aa.tar.gz
python3-wheel: inherit flit_core
Backport pyproject.toml from flit-backend branch. Inherit flit_core class to build Inherit pip_install_wheel to install wheels for target We need to bootstrap python3-wheel-native in order to have bdist_wheel available to python3-setuptools-native and the refactored setuptools3.bbclass. Simply unzip the wheel into PYTHON_SITEPACKAGES_DIR for class-native. [YOCTO #14638] Signed-off-by: Tim Orling <tim.orling@konsulko.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/python/python3-wheel_0.37.1.bb')
-rw-r--r--meta/recipes-devtools/python/python3-wheel_0.37.1.bb16
1 files changed, 14 insertions, 2 deletions
diff --git a/meta/recipes-devtools/python/python3-wheel_0.37.1.bb b/meta/recipes-devtools/python/python3-wheel_0.37.1.bb
index 6c7a31db9e..c7354c9d98 100644
--- a/meta/recipes-devtools/python/python3-wheel_0.37.1.bb
+++ b/meta/recipes-devtools/python/python3-wheel_0.37.1.bb
@@ -6,7 +6,19 @@ LIC_FILES_CHKSUM = "file://PKG-INFO;beginline=10;endline=10;md5=8227180126797a01
SRC_URI[sha256sum] = "e9a504e793efbca1b8e0e9cb979a249cf4a0a7b5b8c9e8b65a5e39d49529c1c4"
-inherit pypi setuptools3
+inherit flit_core pypi setuptools3-base
-BBCLASSEXTEND = "native"
+SRC_URI += " file://0001-Backport-pyproject.toml-from-flit-backend-branch.patch"
+
+DEPENDS:remove:class-native = "python3-pip-native"
+
+do_install:class-native () {
+ # We need to bootstrap python3-wheel-native
+ install -d ${D}${PYTHON_SITEPACKAGES_DIR}
+ PYPA_WHEEL="${B}/dist/${PYPI_PACKAGE}-${PV}-*.whl"
+ unzip -d ${D}${PYTHON_SITEPACKAGES_DIR} ${PYPA_WHEEL} || \
+ bbfatal_log "Failed to install"
+}
+
+BBCLASSEXTEND = "native nativesdk"