summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python3-wheel_0.37.1.bb
diff options
context:
space:
mode:
authorRoss Burton <ross@burtonini.com>2022-03-11 12:03:02 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2022-03-13 12:21:07 +0000
commit3bdf64b97facce9706cc579bdbc9a80e0d48428f (patch)
tree87250844be228d473eb8484324c5cbb70735c38a /meta/recipes-devtools/python/python3-wheel_0.37.1.bb
parent15baf24f750ab2c8b0a46d4a3bf2ae9bfa3d0aff (diff)
downloadopenembedded-core-contrib-3bdf64b97facce9706cc579bdbc9a80e0d48428f.tar.gz
meta: rename pip_install_wheel.bbclass to python_pep517.bbclass
pip_install_wheel shouldn't restricted to just using Pip to install wheels (the installer module is simplier and likely a better option), and in the future may be extended to also provide do_compile() using the build module. Signed-off-by: Ross Burton <ross.burton@arm.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/python/python3-wheel_0.37.1.bb')
-rw-r--r--meta/recipes-devtools/python/python3-wheel_0.37.1.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta/recipes-devtools/python/python3-wheel_0.37.1.bb b/meta/recipes-devtools/python/python3-wheel_0.37.1.bb
index cf0d8191b4..a339e65824 100644
--- a/meta/recipes-devtools/python/python3-wheel_0.37.1.bb
+++ b/meta/recipes-devtools/python/python3-wheel_0.37.1.bb
@@ -13,7 +13,7 @@ SRC_URI += " file://0001-Backport-pyproject.toml-from-flit-backend-branch.patch"
DEPENDS:remove:class-native = "python3-pip-native"
do_install:class-native () {
- pip_install_wheel_do_bootstrap_install
+ python_pep517_do_bootstrap_install
# pip install would normally generate [project.scripts] in ${bindir}
install -d ${D}/${bindir}