summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python3-subunit_1.4.0.bb
diff options
context:
space:
mode:
authorTim Orling <ticotimo@gmail.com>2022-02-22 11:16:49 -0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2022-02-25 15:06:46 +0000
commit1183357dc9ebff0281c195b41f16fa07c79e84a0 (patch)
tree4be1fcf2b0be40f99084acc12684ef4b3455cc37 /meta/recipes-devtools/python/python3-subunit_1.4.0.bb
parentf91009d168bcad5df6b3ca4f5cd4babff5cf682c (diff)
downloadopenembedded-core-contrib-1183357dc9ebff0281c195b41f16fa07c79e84a0.tar.gz
python3-subunit: merge inc; set PIP_INSTALL_PACKAGE
We have not supported python2 for some time now, so there is no reason to maintain a separate python-subunit.inc file. The wheel built by bdist_wheel is named 'python_subunit-*.whl', so set PIP_INSALL_PACKAGE appropriately. Add patch to use vendored _distutils from setuptools. [YOCTO #14638] Signed-off-by: Tim Orling <tim.orling@konsulko.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/python/python3-subunit_1.4.0.bb')
-rw-r--r--meta/recipes-devtools/python/python3-subunit_1.4.0.bb17
1 files changed, 15 insertions, 2 deletions
diff --git a/meta/recipes-devtools/python/python3-subunit_1.4.0.bb b/meta/recipes-devtools/python/python3-subunit_1.4.0.bb
index a06ded868f..bc49a2b69e 100644
--- a/meta/recipes-devtools/python/python3-subunit_1.4.0.bb
+++ b/meta/recipes-devtools/python/python3-subunit_1.4.0.bb
@@ -1,4 +1,17 @@
-inherit setuptools3
-require python-subunit.inc
+SUMMARY = "Python implementation of subunit test streaming protocol"
+HOMEPAGE = "https://pypi.org/project/python-subunit/"
+SECTION = "devel/python"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://README.rst;beginline=1;endline=20;md5=909c08e291647fd985fbe5d9836d51b6"
+
+PYPI_PACKAGE = "python-subunit"
+
+SRC_URI[sha256sum] = "042039928120fbf392e8c983d60f3d8ae1b88f90a9f8fd7188ddd9c26cad1e48"
+
+inherit pypi setuptools3
+
+PIP_INSTALL_PACKAGE = "python_subunit"
RDEPENDS:${PN} = " python3-testtools"
+
+BBCLASSEXTEND = "nativesdk"