aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python3-setuptools_22.0.5.bb
diff options
context:
space:
mode:
authorAlejandro Hernandez <alejandro.hernandez@linux.intel.com>2016-06-08 05:56:08 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-06-12 23:47:16 +0100
commitf69acee1386ac0ba3e3b3b3a962e52a23d18521e (patch)
tree5000dc30861b48640fade67536c032f17919cf55 /meta/recipes-devtools/python/python3-setuptools_22.0.5.bb
parent3411d2d466b86c9bc47a8ac41a0968eb17529ba2 (diff)
downloadopenembedded-core-contrib-f69acee1386ac0ba3e3b3b3a962e52a23d18521e.tar.gz
python-setuptools: Upgrade to 22.0.5
Source location changed on pypi, this must be changed on all other recipes as well, License also changed to MIT (From OE-Core rev: bb2ecb102f30d5165c4e47adadfe5d052c6a06ce) Signed-off-by: Alejandro Hernandez <alejandro.hernandez@linux.intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/python/python3-setuptools_22.0.5.bb')
-rw-r--r--meta/recipes-devtools/python/python3-setuptools_22.0.5.bb37
1 files changed, 37 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python3-setuptools_22.0.5.bb b/meta/recipes-devtools/python/python3-setuptools_22.0.5.bb
new file mode 100644
index 0000000000..fb2931c3f2
--- /dev/null
+++ b/meta/recipes-devtools/python/python3-setuptools_22.0.5.bb
@@ -0,0 +1,37 @@
+require python-setuptools.inc
+
+DEPENDS += "python3"
+DEPENDS_class-native += "python3-native"
+
+inherit distutils3
+
+DISTUTILS_INSTALL_ARGS += "--install-lib=${D}${libdir}/${PYTHON_DIR}/site-packages"
+
+# The installer puts the wrong path in the setuptools.pth file. Correct it.
+do_install_append() {
+ rm ${D}${PYTHON_SITEPACKAGES_DIR}/setuptools.pth
+ mv ${D}${bindir}/easy_install ${D}${bindir}/easy3_install
+ echo "./${SRCNAME}-${PV}-py${PYTHON_BASEVERSION}.egg" > ${D}${PYTHON_SITEPACKAGES_DIR}/setuptools.pth
+}
+
+RDEPENDS_${PN} = "\
+ python3-distutils \
+ python3-compression \
+"
+RDEPENDS_${PN}_class-target = "\
+ python3-ctypes \
+ python3-distutils \
+ python3-email \
+ python3-importlib \
+ python3-numbers \
+ python3-compression \
+ python3-shell \
+ python3-subprocess \
+ python3-textutils \
+ python3-pkgutil \
+ python3-threading \
+ python3-misc \
+ python3-unittest \
+ python3-xml \
+"
+BBCLASSEXTEND = "native"