aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python3-setuptools_19.2.bb
diff options
context:
space:
mode:
authorAlejandro Hernandez <alejandro.hernandez@linux.intel.com>2016-01-19 21:56:24 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-01-19 23:03:15 +0000
commita60ea2c871f5be64e024edf67426e5f5b5c31c5e (patch)
treed169e60a6822179b978b80ff78c98813eff7e791 /meta/recipes-devtools/python/python3-setuptools_19.2.bb
parent9ed4ef038a4a8140accfa97b2eb6b75f8bed3693 (diff)
downloadopenembedded-core-contrib-a60ea2c871f5be64e024edf67426e5f5b5c31c5e.tar.gz
python3-setuptools: upgrade to 19.2
Signed-off-by: Alejandro Hernandez <alejandro.hernandez@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/python/python3-setuptools_19.2.bb')
-rw-r--r--meta/recipes-devtools/python/python3-setuptools_19.2.bb56
1 files changed, 56 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python3-setuptools_19.2.bb b/meta/recipes-devtools/python/python3-setuptools_19.2.bb
new file mode 100644
index 0000000000..bb5798229f
--- /dev/null
+++ b/meta/recipes-devtools/python/python3-setuptools_19.2.bb
@@ -0,0 +1,56 @@
+SUMMARY = "Download, build, install, upgrade, and uninstall Python packages"
+HOMEPAGE = "http://packages.python.org/setuptools"
+SECTION = "devel/python"
+LICENSE = "PSF"
+LIC_FILES_CHKSUM = "file://setup.py;beginline=78;endline=78;md5=8a314270dd7a8dbca741775415f1716e"
+
+SRCNAME = "setuptools"
+DEPENDS += "python3"
+DEPENDS_class-native += "python3-native"
+
+SRC_URI = " \
+ http://pypi.python.org/packages/source/s/${SRCNAME}/${SRCNAME}-${PV}.tar.gz \
+"
+SRC_URI[md5sum] = "78353b1f80375ca5e088f4b4627ffe03"
+SRC_URI[sha256sum] = "f90ed8eb70b14b0594ba74e9de4ffca040c0ec8ee505cbf3570499467859f71a"
+UPSTREAM_CHECK_URI = "https://pypi.python.org/pypi/setuptools"
+
+S = "${WORKDIR}/${SRCNAME}-${PV}"
+
+inherit distutils3
+
+DISTUTILS_INSTALL_ARGS += "--install-lib=${D}${libdir}/${PYTHON_DIR}/site-packages"
+
+do_install_prepend() {
+ install -d ${D}/${libdir}/${PYTHON_DIR}/site-packages
+}
+#
+# The installer puts the wrong path in the setuptools.pth file. Correct it.
+#
+do_install_append() {
+ rm ${D}${PYTHON_SITEPACKAGES_DIR}/setuptools.pth
+ mv ${D}${bindir}/easy_install ${D}${bindir}/easy3_install
+ echo "./${SRCNAME}-${PV}-py${PYTHON_BASEVERSION}.egg" > ${D}${PYTHON_SITEPACKAGES_DIR}/setuptools.pth
+}
+
+RDEPENDS_${PN} = "\
+ python3-distutils \
+ python3-compression \
+"
+RDEPENDS_${PN}_class-target = "\
+ python3-ctypes \
+ python3-distutils \
+ python3-email \
+ python3-importlib \
+ python3-numbers \
+ python3-compression \
+ python3-shell \
+ python3-subprocess \
+ python3-textutils \
+ python3-pkgutil \
+ python3-threading \
+ python3-misc \
+ python3-unittest \
+ python3-xml \
+"
+BBCLASSEXTEND = "native"