summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python3-pygobject_3.42.1.bb
diff options
context:
space:
mode:
authorAlexander Kanavin <alex.kanavin@gmail.com>2022-05-05 07:05:22 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2022-05-05 21:17:13 +0100
commite4f371ea27ec1dba8a59e3e5a56646042427018d (patch)
treeff9602a67c1ec31f1d6461571405a2eccd824065 /meta/recipes-devtools/python/python3-pygobject_3.42.1.bb
parent1e58fa1fff649a4ab07290d2b0e5a8d69d51ef16 (diff)
downloadopenembedded-core-contrib-e4f371ea27ec1dba8a59e3e5a56646042427018d.tar.gz
python3-pygobject: upgrade 3.42.0 -> 3.42.1
Signed-off-by: Alexander Kanavin <alex@linutronix.de> Signed-off-by: Luca Ceresoli <luca.ceresoli@bootlin.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/python/python3-pygobject_3.42.1.bb')
-rw-r--r--meta/recipes-devtools/python/python3-pygobject_3.42.1.bb34
1 files changed, 34 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python3-pygobject_3.42.1.bb b/meta/recipes-devtools/python/python3-pygobject_3.42.1.bb
new file mode 100644
index 0000000000..443605ae26
--- /dev/null
+++ b/meta/recipes-devtools/python/python3-pygobject_3.42.1.bb
@@ -0,0 +1,34 @@
+SUMMARY = "Python GObject bindings"
+HOMEPAGE = "https://gitlab.gnome.org/GNOME/pygobject"
+DESCRIPTION = "PyGObject is a Python package which provides bindings for GObject based libraries such as GTK, GStreamer, WebKitGTK, GLib, GIO and many more."
+SECTION = "devel/python"
+LICENSE = "LGPL-2.1-only"
+LIC_FILES_CHKSUM = "file://COPYING;md5=a916467b91076e631dd8edb7424769c7"
+
+GNOMEBASEBUILDCLASS = "meson"
+GIR_MESON_OPTION = ""
+
+inherit gnomebase setuptools3-base gobject-introspection upstream-version-is-even
+
+DEPENDS += "python3 glib-2.0"
+
+SRCNAME="pygobject"
+
+SRC_URI = " \
+ http://ftp.gnome.org/pub/GNOME/sources/${SRCNAME}/${@gnome_verdir("${PV}")}/${SRCNAME}-${PV}.tar.xz \
+ file://0001-Do-not-build-tests.patch \
+"
+SRC_URI[sha256sum] = "1f34b5f7624de35e44eb5a7eb428353285bd03004d55131a5f7f7fa9b90f3cc9"
+
+S = "${WORKDIR}/${SRCNAME}-${PV}"
+
+PACKAGECONFIG ??= "${@bb.utils.contains_any('DISTRO_FEATURES', [ 'directfb', 'wayland', 'x11' ], 'cairo', '', d)}"
+
+RDEPENDS:${PN} += "python3-pkgutil"
+
+# python3-pycairo is checked on configuration -> DEPENDS
+# we don't link against python3-pycairo -> RDEPENDS
+PACKAGECONFIG[cairo] = "-Dpycairo=enabled,-Dpycairo=disabled, cairo python3-pycairo, python3-pycairo"
+
+BBCLASSEXTEND = "native"
+PACKAGECONFIG:class-native = ""