aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python3-pygobject_3.28.1.bb
diff options
context:
space:
mode:
authorDerek Straka <derek@asterius.io>2018-03-18 09:35:20 -0400
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-03-20 09:30:17 +0000
commitaa33df15dca690b6556794b604cb99bd13dbce72 (patch)
tree7dbf5f39003fdd75669a8bec88c1fa05d9eafa05 /meta/recipes-devtools/python/python3-pygobject_3.28.1.bb
parent8422880acf65802dbaa08238ae9e63670ed49ff3 (diff)
downloadopenembedded-core-contrib-aa33df15dca690b6556794b604cb99bd13dbce72.tar.gz
python3-pygobject: update to 3.28.1
Update to the latest stable release Tested in qemux86-64 running core-image-minimal Signed-off-by: Derek Straka <derek@asterius.io> Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta/recipes-devtools/python/python3-pygobject_3.28.1.bb')
-rw-r--r--meta/recipes-devtools/python/python3-pygobject_3.28.1.bb29
1 files changed, 29 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python3-pygobject_3.28.1.bb b/meta/recipes-devtools/python/python3-pygobject_3.28.1.bb
new file mode 100644
index 0000000000..ad0117a2f4
--- /dev/null
+++ b/meta/recipes-devtools/python/python3-pygobject_3.28.1.bb
@@ -0,0 +1,29 @@
+SUMMARY = "Python GObject bindings"
+SECTION = "devel/python"
+LICENSE = "LGPLv2.1"
+LIC_FILES_CHKSUM = "file://COPYING;md5=a916467b91076e631dd8edb7424769c7"
+
+inherit autotools pkgconfig gnomebase distutils3-base gobject-introspection upstream-version-is-even
+
+DEPENDS += "python3 glib-2.0"
+
+SRCNAME="pygobject"
+SRC_URI = " \
+ http://ftp.gnome.org/pub/GNOME/sources/${SRCNAME}/${@gnome_verdir("${PV}")}/${SRCNAME}-${PV}.tar.xz \
+"
+
+SRC_URI[md5sum] = "612e9e2863d117d810e78672f7bc3ad6"
+SRC_URI[sha256sum] = "42312b4a5015571fa0a4f2d201005da46b71c251ea2625bc95702d071c4ff895"
+
+S = "${WORKDIR}/${SRCNAME}-${PV}"
+
+PACKAGECONFIG ??= "${@bb.utils.contains_any('DISTRO_FEATURES', [ 'directfb', 'wayland', 'x11' ], 'cairo', '', d)}"
+
+# python3-pycairo is checked on configuration -> DEPENDS
+# we don't link against python3-pycairo -> RDEPENDS
+PACKAGECONFIG[cairo] = "--enable-cairo,--disable-cairo,cairo python3-pycairo, python3-pycairo"
+
+RDEPENDS_${PN} += "python3-setuptools"
+
+BBCLASSEXTEND = "native"
+PACKAGECONFIG_class-native = ""