summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python3-pygments_2.7.3.bb
diff options
context:
space:
mode:
authorTim Orling <timothy.t.orling@linux.intel.com>2020-12-08 13:21:15 -0800
committerTim Orling <timothy.t.orling@linux.intel.com>2020-12-08 16:24:03 -0800
commit727588d22d05bc6f95b5fb7409c69ff55432d1ed (patch)
tree053ca79caae46c2387511a131263f5300b7e14b6 /meta/recipes-devtools/python/python3-pygments_2.7.3.bb
parent3ed25611065ac11429a225d650ba9a3a4856d258 (diff)
downloadopenembedded-core-contrib-727588d22d05bc6f95b5fb7409c69ff55432d1ed.tar.gz
python3-pygments: upgrade v2.7.2 -> v2.7.3
Upstream release notes: """ * Updated lexers: - Ada (#1581) - HTML (#1615, #1614) - Java (#1594, #1586) - JavaScript (#1605, #1589, #1588) - JSON (#1569 -- this is a complete rewrite) - Lean (#1601) - LLVM (#1612) - Mason (#1592) - MySQL (#1555, #1551) - Rust (#1608) - Turtle (#1590, #1553) * Deprecated JsonBareObjectLexer, which is now identical to JsonLexer (#1600) * The ImgFormatter now calculates the exact character width, which fixes some issues with overlapping text (#1213, #1611) * Documentation fixes (#1609, #1599, #1598) * Fixed duplicated Juttle language alias (#1604, #1606) * Added support for Kotlin scripts (#1587) * Removed CSS rule which forced margin to 0 """ Signed-off-by: Tim Orling <timothy.t.orling@linux.intel.com>
Diffstat (limited to 'meta/recipes-devtools/python/python3-pygments_2.7.3.bb')
-rw-r--r--meta/recipes-devtools/python/python3-pygments_2.7.3.bb19
1 files changed, 19 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python3-pygments_2.7.3.bb b/meta/recipes-devtools/python/python3-pygments_2.7.3.bb
new file mode 100644
index 0000000000..379d85dbd7
--- /dev/null
+++ b/meta/recipes-devtools/python/python3-pygments_2.7.3.bb
@@ -0,0 +1,19 @@
+SUMMARY = "Pygments is a syntax highlighting package written in Python."
+DESCRIPTION = "Pygments is a syntax highlighting package written in Python."
+HOMEPAGE = "http://pygments.org/"
+LICENSE = "BSD-2-Clause"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=1f5d0c4cf38dfc8122c00d6f1a97a0cc"
+
+inherit setuptools3
+SRC_URI[sha256sum] = "ccf3acacf3782cbed4a989426012f1c535c9a90d3a7fc3f16d231b9372d2b716"
+
+DEPENDS += "\
+ ${PYTHON_PN} \
+ "
+
+PYPI_PACKAGE = "Pygments"
+
+inherit pypi
+
+BBCLASSEXTEND = "native nativesdk"
+