aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python3-pip_9.0.3.bb
diff options
context:
space:
mode:
authorDerek Straka <derek@asterius.io>2018-03-24 10:23:52 -0400
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-05-04 09:54:49 +0100
commit67db8d72389669cd854e46cbacb3e8b6dfc5a044 (patch)
tree360d475fc40b1d9b15413638b0d48fbcbe8fe0de /meta/recipes-devtools/python/python3-pip_9.0.3.bb
parentd549289fa518a44274911d0959945196bbff930f (diff)
downloadopenembedded-core-contrib-67db8d72389669cd854e46cbacb3e8b6dfc5a044.tar.gz
python3-pip: update to version 9.0.3
Update to the latest stable version Signed-off-by: Derek Straka <derek@asterius.io> Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta/recipes-devtools/python/python3-pip_9.0.3.bb')
-rw-r--r--meta/recipes-devtools/python/python3-pip_9.0.3.bb48
1 files changed, 48 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python3-pip_9.0.3.bb b/meta/recipes-devtools/python/python3-pip_9.0.3.bb
new file mode 100644
index 0000000000..850556d797
--- /dev/null
+++ b/meta/recipes-devtools/python/python3-pip_9.0.3.bb
@@ -0,0 +1,48 @@
+SUMMARY = "The PyPA recommended tool for installing Python packages"
+HOMEPAGE = "https://pypi.python.org/pypi/pip"
+SECTION = "devel/python"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=25fba45109565f87de20bae85bc39452"
+
+DEPENDS += "python3 python3-setuptools-native"
+
+SRC_URI[md5sum] = "b15b33f9aad61f88d0f8c866d16c55d8"
+SRC_URI[sha256sum] = "7bf48f9a693be1d58f49f7af7e0ae9fe29fd671cde8a55e6edca3581c4ef5796"
+
+inherit pypi distutils3
+
+DISTUTILS_INSTALL_ARGS += "--install-lib=${D}${PYTHON_SITEPACKAGES_DIR}"
+
+do_install_prepend() {
+ install -d ${D}${PYTHON_SITEPACKAGES_DIR}
+}
+
+# Use setuptools site.py instead, avoid shared state issue
+do_install_append() {
+ rm ${D}${PYTHON_SITEPACKAGES_DIR}/site.py
+ rm ${D}${PYTHON_SITEPACKAGES_DIR}/__pycache__/site.cpython-*.pyc
+
+ # Install as pip3 and leave pip2 as default
+ rm ${D}/${bindir}/pip
+
+ # Installed eggs need to be passed directly to the interpreter via a pth file
+ echo "./${PYPI_PACKAGE}-${PV}-py${PYTHON_BASEVERSION}.egg" > ${D}${PYTHON_SITEPACKAGES_DIR}/${PYPI_PACKAGE}-${PV}.pth
+
+ # Make sure we use /usr/bin/env python3
+ for PYTHSCRIPT in `grep -rIl ${bindir} ${D}${bindir}/pip3*`; do
+ sed -i -e '1s|^#!.*|#!/usr/bin/env python3|' $PYTHSCRIPT
+ done
+}
+
+RDEPENDS_${PN} = "\
+ python3-compile \
+ python3-io \
+ python3-html \
+ python3-json \
+ python3-netserver \
+ python3-setuptools \
+ python3-unixadmin \
+ python3-xmlrpc \
+"
+
+BBCLASSEXTEND = "native nativesdk"