summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python3-more-itertools_8.6.0.bb
diff options
context:
space:
mode:
authorTim Orling <timothy.t.orling@linux.intel.com>2020-11-27 20:24:29 -0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2020-11-30 14:40:55 +0000
commit16c211427056a4bfc3545202ea485247a72c832a (patch)
tree3c3677a773212cf19c93ba469e8a13afa6cefbdc /meta/recipes-devtools/python/python3-more-itertools_8.6.0.bb
parent4cda7821f7a588a9106d63f3efcd1c06dcfa4f5d (diff)
downloadopenembedded-core-contrib-16c211427056a4bfc3545202ea485247a72c832a.tar.gz
python3-more-itertools: upgrade 8.5.0 -> 8.6.0
Upstream release notes: " * New itertools - all_unique (thanks to brianmaissy) - nth_product and nth_permutation (thanks to N8Brooks) * Changes to existing itertools - chunked and sliced now accept a strict parameter (thanks to shlomif and jtwool) * Other changes - Python 3.5 has reached its end of life and is no longer supported. - Python 3.9 is officially supported. - Various documentation fixes (thanks to timgates42) Signed-off-by: Tim Orling <timothy.t.orling@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/python/python3-more-itertools_8.6.0.bb')
-rw-r--r--meta/recipes-devtools/python/python3-more-itertools_8.6.0.bb23
1 files changed, 23 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python3-more-itertools_8.6.0.bb b/meta/recipes-devtools/python/python3-more-itertools_8.6.0.bb
new file mode 100644
index 0000000000..ee5ce7ba9c
--- /dev/null
+++ b/meta/recipes-devtools/python/python3-more-itertools_8.6.0.bb
@@ -0,0 +1,23 @@
+DESCRIPTION = "More routines for operating on iterables, beyond itertools"
+HOMEPAGE = "https://github.com/erikrose/more-itertools"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=3396ea30f9d21389d7857719816f83b5"
+
+SRC_URI[sha256sum] = "b3a9005928e5bed54076e6e549c792b306fddfe72b2d1d22dd63d42d5d3899cf"
+
+inherit pypi setuptools3 ptest
+
+SRC_URI += " \
+ file://run-ptest \
+"
+
+RDEPENDS_${PN}-ptest += " \
+ ${PYTHON_PN}-pytest \
+"
+
+do_install_ptest() {
+ install -d ${D}${PTEST_PATH}/tests
+ cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
+}
+
+BBCLASSEXTEND = "native nativesdk"