summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python3-jsonschema_4.6.0.bb
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@arm.com>2022-06-21 14:10:11 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2022-06-22 22:40:25 +0100
commitee9a40d5d433d2babb010e11973a97f651d074e9 (patch)
treec6faf73ab2b91a16d28cf4ddaff25e9fee7d8131 /meta/recipes-devtools/python/python3-jsonschema_4.6.0.bb
parent62cb0c78e2ea4cfbb7bb961abd9b8faaa2100379 (diff)
downloadopenembedded-core-contrib-ee9a40d5d433d2babb010e11973a97f651d074e9.tar.gz
python3-jsonschema: upgrade 4.5.1 -> 4.6.0
Switch the build system from setuptools to hatch. Signed-off-by: Ross Burton <ross.burton@arm.com> Signed-off-by: Luca Ceresoli <luca.ceresoli@bootlin.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/python/python3-jsonschema_4.6.0.bb')
-rw-r--r--meta/recipes-devtools/python/python3-jsonschema_4.6.0.bb48
1 files changed, 48 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python3-jsonschema_4.6.0.bb b/meta/recipes-devtools/python/python3-jsonschema_4.6.0.bb
new file mode 100644
index 0000000000..edd7fafc77
--- /dev/null
+++ b/meta/recipes-devtools/python/python3-jsonschema_4.6.0.bb
@@ -0,0 +1,48 @@
+SUMMARY = "An implementation of JSON Schema validation for Python"
+HOMEPAGE = "https://github.com/Julian/jsonschema"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://COPYING;md5=7a60a81c146ec25599a3e1dabb8610a8 \
+ file://json/LICENSE;md5=9d4de43111d33570c8fe49b4cb0e01af"
+
+SRC_URI[sha256sum] = "9d6397ba4a6c0bf0300736057f649e3e12ecbc07d3e81a0dacb72de4e9801957"
+
+inherit pypi python_hatchling
+
+DEPENDS += "${PYTHON_PN}-hatch-vcs-native"
+
+PACKAGECONFIG ??= "format"
+PACKAGECONFIG[format] = ",,,\
+ ${PYTHON_PN}-idna \
+ ${PYTHON_PN}-jsonpointer \
+ ${PYTHON_PN}-webcolors \
+ ${PYTHON_PN}-rfc3987 \
+ ${PYTHON_PN}-strict-rfc3339 \
+"
+PACKAGECONFIG[nongpl] = ",,,\
+ ${PYTHON_PN}-idna \
+ ${PYTHON_PN}-jsonpointer \
+ ${PYTHON_PN}-webcolors \
+ ${PYTHON_PN}-rfc3986-validator \
+ ${PYTHON_PN}-rfc3339-validator \
+"
+
+RDEPENDS:${PN} += " \
+ ${PYTHON_PN}-attrs \
+ ${PYTHON_PN}-core \
+ ${PYTHON_PN}-datetime \
+ ${PYTHON_PN}-importlib-metadata \
+ ${PYTHON_PN}-io \
+ ${PYTHON_PN}-json \
+ ${PYTHON_PN}-netclient \
+ ${PYTHON_PN}-numbers \
+ ${PYTHON_PN}-pkgutil \
+ ${PYTHON_PN}-pprint \
+ ${PYTHON_PN}-pyrsistent \
+ ${PYTHON_PN}-shell \
+ ${PYTHON_PN}-six \
+ ${PYTHON_PN}-unittest \
+ ${PYTHON_PN}-setuptools-scm \
+ ${PYTHON_PN}-zipp \
+"
+
+BBCLASSEXTEND = "native nativesdk"