summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python3-importlib-metadata_4.8.1.bb
diff options
context:
space:
mode:
authorTim Orling <ticotimo@gmail.com>2021-10-12 02:08:49 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2021-10-14 11:48:35 +0100
commit21d72ace8f9486bd1b478e28d53da64087d790fa (patch)
treeb7410ac16a4ca035deef7786d6ab459ec816b937 /meta/recipes-devtools/python/python3-importlib-metadata_4.8.1.bb
parentb01db599d754f7fe654ae4edfc076333b54bbce5 (diff)
downloadopenembedded-core-contrib-21d72ace8f9486bd1b478e28d53da64087d790fa.tar.gz
python3-importlib-metadata: upgrade 4.6.4 -> 4.8.1
v4.8.1 #348: Restored support for EntryPoint access by item, deprecating support in the process. Users are advised to use direct member access instead of item-based access: - ep[0] -> ep.name - ep[1] -> ep.value - ep[2] -> ep.group - ep[:] -> ep.name, ep.value, ep.group v4.8.0 #337: Rewrote EntryPoint as a simple class, still immutable and still with the attributes, but without any expectation for namedtuple functionality such as _asdict. v4.7.1 #344: Fixed regression in packages_distributions when neither top-level.txt nor a files manifest is present. v4.7.0 #330: In packages_distributions, now infer top-level names from .files() when a top-level.txt (Setuptools-specific metadata) is not present. References: https://github.com/python/importlib_metadata/issues/348 https://github.com/python/importlib_metadata/issues/337 https://github.com/python/importlib_metadata/issues/344 https://github.com/python/importlib_metadata/issues/330 Signed-off-by: Tim Orling <timothy.t.orling@intel.com> Signed-off-by: Alexandre Belloni <alexandre.belloni@bootlin.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/python/python3-importlib-metadata_4.8.1.bb')
-rw-r--r--meta/recipes-devtools/python/python3-importlib-metadata_4.8.1.bb20
1 files changed, 20 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python3-importlib-metadata_4.8.1.bb b/meta/recipes-devtools/python/python3-importlib-metadata_4.8.1.bb
new file mode 100644
index 0000000000..3f75668431
--- /dev/null
+++ b/meta/recipes-devtools/python/python3-importlib-metadata_4.8.1.bb
@@ -0,0 +1,20 @@
+DESCRIPTION = "Read metadata from Python packages"
+HOMEPAGE = "https://pypi.org/project/importlib-metadata/"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=e88ae122f3925d8bde8319060f2ddb8e"
+
+inherit pypi setuptools3
+
+PYPI_PACKAGE = "importlib_metadata"
+UPSTREAM_CHECK_REGEX = "/importlib-metadata/(?P<pver>(\d+[\.\-_]*)+)/"
+
+SRC_URI[sha256sum] = "f284b3e11256ad1e5d03ab86bb2ccd6f5339688ff17a4d797a0fe7df326f23b1"
+
+S = "${WORKDIR}/importlib_metadata-${PV}"
+
+DEPENDS += "${PYTHON_PN}-setuptools-scm-native ${PYTHON_PN}-toml-native"
+RDEPENDS:${PN} += "${PYTHON_PN}-zipp ${PYTHON_PN}-pathlib2"
+RDEPENDS:${PN}:append:class-target = " python3-misc"
+RDEPENDS:${PN}:append:class-nativesdk = " python3-misc"
+
+BBCLASSEXTEND = "native nativesdk"