summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python3-importlib-metadata_3.1.1.bb
diff options
context:
space:
mode:
authorTim Orling <timothy.t.orling@linux.intel.com>2020-12-08 16:35:44 -0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2020-12-10 13:40:19 +0000
commit77268917f2bb947982306f23925d752a318e266d (patch)
tree301a695938849cb1b22f7502652df43e78f00860 /meta/recipes-devtools/python/python3-importlib-metadata_3.1.1.bb
parenteebc9eb0d172a31674c6f7117716e578890c20cb (diff)
downloadopenembedded-core-contrib-77268917f2bb947982306f23925d752a318e266d.tar.gz
python3-importlib-metadata: upgrade 3.1.0 -> 3.1.1
No upstream release notes. Commits since 3.1.0 tag: 155bc48 (HEAD, tag: v3.1.1) Merge branch 'maint/2.x' 83c7dd2 (tag: v2.1.1, origin/maint/2.x) Merge pull request #264 from python/bugfix/261-versionless-egg-info-pre-normalized-fallback 4cb3bd0 Update changelog. Ref #261. 6036a37 Avoid relying on new-style normalization for legacy eggs. 4098b51 Perform exact match on Prepared.normalized, and then add a separate check for an empty self.normalized instead of relying on a degenerate result from startswith. 7bdbb57 Add test to ensure that a prefix isn't matched 595eb5f Compare the name against self.normalized. Fixes #261 but also will cause 'lib' to match 'lib_foo'. fea6e75 Move is_egg into prepared. 313535a Extract method for matching a name in a prepared search. 4335def Add test capturing expectation where versionless metadata exists but hasn't been updated to the new normalization technique. Ref #261. 9aee90b Fix syntax in changelog 55e64a4 Merge pull request #258 from python/feature/skeleton 8721a05 Merge branch 'master' into feature/skeleton ed672ee Consolidate coverage files eabd24d Restore diffcov b29baea Correct syntax for invoking pytest d5a5c90 Bring back perf 67cb123 Run tests to exercise coverage Signed-off-by: Tim Orling <timothy.t.orling@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/python/python3-importlib-metadata_3.1.1.bb')
-rw-r--r--meta/recipes-devtools/python/python3-importlib-metadata_3.1.1.bb18
1 files changed, 18 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python3-importlib-metadata_3.1.1.bb b/meta/recipes-devtools/python/python3-importlib-metadata_3.1.1.bb
new file mode 100644
index 0000000000..56b57cc32a
--- /dev/null
+++ b/meta/recipes-devtools/python/python3-importlib-metadata_3.1.1.bb
@@ -0,0 +1,18 @@
+DESCRIPTION = "Read metadata from Python packages"
+HOMEPAGE = "https://pypi.org/project/importlib-metadata/"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=e88ae122f3925d8bde8319060f2ddb8e"
+
+inherit pypi setuptools3
+
+SRC_URI = "https://files.pythonhosted.org/packages/3f/a8/16dc098b0addd1c20719c18a86e985be851b3ec1e103e703297169bb22cc/importlib_metadata-3.1.1.tar.gz"
+SRC_URI[sha256sum] = "b0c2d3b226157ae4517d9625decf63591461c66b3a808c2666d538946519d170"
+
+S = "${WORKDIR}/importlib_metadata-${PV}"
+
+DEPENDS += "${PYTHON_PN}-setuptools-scm-native"
+RDEPENDS_${PN} += "${PYTHON_PN}-zipp ${PYTHON_PN}-pathlib2"
+RDEPENDS_${PN}_append_class-target = " python3-misc"
+RDEPENDS_${PN}_append_class-nativesdk = " python3-misc"
+
+BBCLASSEXTEND = "native nativesdk"