summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python3-git_2.1.12.bb
diff options
context:
space:
mode:
authorOleksandr Kravchuk <open.source@oleksandr-kravchuk.com>2019-07-24 22:19:31 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2019-07-26 08:40:59 +0100
commitdd9d95e8394a7a318538c7cabd27c82e4bc9e029 (patch)
tree2dceded6f323da4035b9473314955aef9070de79 /meta/recipes-devtools/python/python3-git_2.1.12.bb
parent73f69585e9f30819d8fb484d458e3408a04c0433 (diff)
downloadopenembedded-core-contrib-dd9d95e8394a7a318538c7cabd27c82e4bc9e029.tar.gz
python3-git: update to 2.1.12
Got rid of python-git since there is no python2 version of the package. Signed-off-by: Oleksandr Kravchuk <open.source@oleksandr-kravchuk.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/python/python3-git_2.1.12.bb')
-rw-r--r--meta/recipes-devtools/python/python3-git_2.1.12.bb33
1 files changed, 33 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python3-git_2.1.12.bb b/meta/recipes-devtools/python/python3-git_2.1.12.bb
new file mode 100644
index 0000000000..380371f783
--- /dev/null
+++ b/meta/recipes-devtools/python/python3-git_2.1.12.bb
@@ -0,0 +1,33 @@
+SUMMARY = "Python library used to interact with Git repositories"
+DESCRIPTION = "GitPython provides object model read and write access to \
+a git repository. Access repository information conveniently, alter the \
+index directly, handle remotes, or go down to low-level object database \
+access with big-files support."
+HOMEPAGE = "http://github.com/gitpython-developers/GitPython"
+SECTION = "devel/python"
+LICENSE = "BSD-3-Clause"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=8b8d26c37c1d5a04f9b0186edbebc183"
+
+PYPI_PACKAGE = "GitPython"
+
+inherit pypi setuptools3
+
+SRC_URI[md5sum] = "33bfbc89fe616ca22b6336be80d570f4"
+SRC_URI[sha256sum] = "7428f1cc5e72d53e65c3259d5cebc22fb2b07f973c49d95b3c3d26c64890a3c3"
+
+DEPENDS += " ${PYTHON_PN}-gitdb"
+
+RDEPENDS_${PN} += " \
+ ${PYTHON_PN}-datetime \
+ ${PYTHON_PN}-gitdb \
+ ${PYTHON_PN}-io \
+ ${PYTHON_PN}-logging \
+ ${PYTHON_PN}-math \
+ ${PYTHON_PN}-netclient \
+ ${PYTHON_PN}-stringold \
+ ${PYTHON_PN}-unittest \
+ ${PYTHON_PN}-unixadmin \
+ git \
+"
+
+BBCLASSEXTEND = "native nativesdk"