aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python-setuptools_18.2.bb
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2015-08-26 01:40:56 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-08-30 12:34:27 +0100
commit58d9f06b2d467dcff781fecf4cbf03b0b7e25432 (patch)
tree5faeab2a4b2e05872492e3ae9b17047bed517517 /meta/recipes-devtools/python/python-setuptools_18.2.bb
parent7b4fbbf979ed22434b8e3f83ae145139bb0d9fc7 (diff)
downloadopenembedded-core-contrib-58d9f06b2d467dcff781fecf4cbf03b0b7e25432.tar.gz
python-distribute, python-setuptools: Migrate to good old python-setuptools
setuptools the old king is ruling again, distribute fork has been merged into setuptools starting 0.7x, so lets move to use it as well Remove licence ambiguity we need to say which verison of PSF and Zope license is in use Fixes [YOCTO #8201] Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta/recipes-devtools/python/python-setuptools_18.2.bb')
-rw-r--r--meta/recipes-devtools/python/python-setuptools_18.2.bb46
1 files changed, 46 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python-setuptools_18.2.bb b/meta/recipes-devtools/python/python-setuptools_18.2.bb
new file mode 100644
index 0000000000..1de2b2e927
--- /dev/null
+++ b/meta/recipes-devtools/python/python-setuptools_18.2.bb
@@ -0,0 +1,46 @@
+SUMMARY = "Downloads, builds, installs, upgrades, and uninstalls Python packages"
+HOMEPAGE = "https://pypi.python.org/pypi/setuptools"
+SECTION = "devel/python"
+LICENSE = "Python-2.0 | ZPL-2.0"
+LIC_FILES_CHKSUM = "file://setup.py;beginline=78;endline=78;md5=8a314270dd7a8dbca741775415f1716e"
+
+SRCNAME = "setuptools"
+
+PROVIDES = "python-distribute"
+
+DEPENDS += "python"
+DEPENDS_class-native += "python-native"
+
+inherit distutils
+
+SRC_URI = "https://pypi.python.org/packages/source/s/setuptools/setuptools-${PV}.tar.gz"
+SRC_URI[md5sum] = "52b4e48939ef311d7204f8fe940764f4"
+SRC_URI[sha256sum] = "0994a58df27ea5dc523782a601357a2198b7493dcc99a30d51827a23585b5b1d"
+
+S = "${WORKDIR}/${SRCNAME}-${PV}"
+
+
+DISTUTILS_INSTALL_ARGS += "--install-lib=${D}${libdir}/${PYTHON_DIR}/site-packages"
+
+do_install_prepend() {
+ install -d ${D}/${libdir}/${PYTHON_DIR}/site-packages
+}
+
+RDEPENDS_${PN} = "\
+ python-stringold \
+ python-email \
+ python-shell \
+ python-distutils \
+ python-compression \
+"
+
+RDEPENDS_${PN}_class-native = "\
+ python-distutils \
+ python-compression \
+"
+
+RREPLACES_${PN} = "python-distribute"
+RPROVIDES_${PN} = "python-distribute"
+RCONFLICTS_${PN} = "python-distribute"
+
+BBCLASSEXTEND = "native nativesdk"