aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python-setuptools.inc
diff options
context:
space:
mode:
authorAlejandro Hernandez <alejandro.hernandez@linux.intel.com>2016-01-21 16:46:06 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-01-22 23:42:45 +0000
commit7a42b4c01a0e1fa335ba1c679369d455235ea6ee (patch)
treedde6ed060f406dcac1268a4487bc15ab353e424f /meta/recipes-devtools/python/python-setuptools.inc
parentee0281c6c0ed92ba3eb69f55a1550b3c60d7981a (diff)
downloadopenembedded-core-contrib-7a42b4c01a0e1fa335ba1c679369d455235ea6ee.tar.gz
python-setuptools: Unify and upgrade python-setuptools and python3-setuptools to 19.4
Signed-off-by: Alejandro Hernandez <alejandro.hernandez@linux.intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta/recipes-devtools/python/python-setuptools.inc')
-rw-r--r--meta/recipes-devtools/python/python-setuptools.inc21
1 files changed, 21 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python-setuptools.inc b/meta/recipes-devtools/python/python-setuptools.inc
new file mode 100644
index 0000000000..0917e88ab6
--- /dev/null
+++ b/meta/recipes-devtools/python/python-setuptools.inc
@@ -0,0 +1,21 @@
+SUMMARY = "Download, build, install, upgrade, and uninstall Python packages"
+HOMEPAGE = "https://pypi.python.org/pypi/setuptools"
+SECTION = "devel/python"
+LICENSE = "PSF | ZPL-2.0"
+
+LIC_FILES_CHKSUM = "file://setup.py;beginline=78;endline=78;md5=8a314270dd7a8dbca741775415f1716e"
+
+SRCNAME = "setuptools"
+
+SRC_URI = "http://pypi.python.org/packages/source/s/${SRCNAME}/${SRCNAME}-${PV}.tar.gz"
+
+SRC_URI[md5sum] = "c5a7d90c1e0acf8c4ec5c2bf31bc25b5"
+SRC_URI[sha256sum] = "214bf29933f47cf25e6faa569f710731728a07a19cae91ea64f826051f68a8cf"
+
+UPSTREAM_CHECK_URI = "https://pypi.python.org/pypi/setuptools"
+
+S = "${WORKDIR}/${SRCNAME}-${PV}"
+
+do_install_prepend() {
+ install -d ${D}/${libdir}/${PYTHON_DIR}/site-packages
+}