summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python-scons_3.0.1.bb
diff options
context:
space:
mode:
authorTim Orling <timothy.t.orling@linux.intel.com>2017-11-18 18:28:56 -0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-12-13 13:59:46 +0000
commitcf5c44ac611c2c2657e6fd3c1f723bcb20b812dd (patch)
treedc0853a1cfb7a13720dbce83ad0a659a572a0ba3 /meta/recipes-devtools/python/python-scons_3.0.1.bb
parentaa458b5fdb8d5d0ac93ced3b198bef2daa4e24b4 (diff)
downloadopenembedded-core-contrib-cf5c44ac611c2c2657e6fd3c1f723bcb20b812dd.tar.gz
python-scons: upgrade to v3.0.1; use pypi.bbclass
* Simplify recipe by using pypi.bbclass * Drop patch for __future__ print_function - fixed upstream: https://github.com/SConsProject/scons/pull/1/commits/4c199d06e76afb9379e76942d0f68caa57f42509 Signed-off-by: Tim Orling <timothy.t.orling@linux.intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta/recipes-devtools/python/python-scons_3.0.1.bb')
-rw-r--r--meta/recipes-devtools/python/python-scons_3.0.1.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python-scons_3.0.1.bb b/meta/recipes-devtools/python/python-scons_3.0.1.bb
new file mode 100644
index 0000000000..2f75b08d25
--- /dev/null
+++ b/meta/recipes-devtools/python/python-scons_3.0.1.bb
@@ -0,0 +1,22 @@
+SUMMARY = "Software Construction tool (make/autotools replacement)"
+SECTION = "devel/python"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=46ddf66004e5be5566367cb525a66fc6"
+
+SRC_URI[md5sum] = "b6a292e251b34b82c203b56cfa3968b3"
+SRC_URI[sha256sum] = "24475e38d39c19683bc88054524df018fe6949d70fbd4c69e298d39a0269f173"
+
+UPSTREAM_CHECK_URI = "http://scons.org/pages/download.html"
+UPSTREAM_CHECK_REGEX = "(?P<pver>\d+(\.\d+)+)\.tar"
+
+inherit pypi setuptools
+
+RDEPENDS_${PN} = "\
+ python-fcntl \
+ python-io \
+ python-json \
+ python-subprocess \
+ python-shell \
+ python-pprint \
+ python-importlib \
+ "