aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python-pycurl
diff options
context:
space:
mode:
authorLaurentiu Palcu <laurentiu.palcu@intel.com>2014-02-06 17:29:32 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-02-08 21:03:27 +0000
commitb5b4898cd409036161c62891e9618d9ab3f891f9 (patch)
tree9ef27df66a47889db28b9cd492cf64bf02bb1c27 /meta/recipes-devtools/python/python-pycurl
parentb18fb872baa0deb89f1b8250883122fb5f6328c5 (diff)
downloadopenembedded-core-contrib-b5b4898cd409036161c62891e9618d9ab3f891f9.tar.gz
python-pycurl: upgrade to 7.19.3
Changes: * Refreshed no-static-link.patch; * LGPL&MIT license files changed names; * MIT license file added a contributor to the list; * README.rst license snippet changed to reflect the filename changes and the new contributor; Signed-off-by: Laurentiu Palcu <laurentiu.palcu@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/python/python-pycurl')
-rw-r--r--meta/recipes-devtools/python/python-pycurl/no-static-link.patch20
1 files changed, 11 insertions, 9 deletions
diff --git a/meta/recipes-devtools/python/python-pycurl/no-static-link.patch b/meta/recipes-devtools/python/python-pycurl/no-static-link.patch
index e8c0005a77..907380f1ca 100644
--- a/meta/recipes-devtools/python/python-pycurl/no-static-link.patch
+++ b/meta/recipes-devtools/python/python-pycurl/no-static-link.patch
@@ -1,15 +1,17 @@
Upstream-Status: Pending
-Index: pycurl-7.19.0.2/setup.py
+Signed-off-by: Laurentiu Palcu <laurentiu.palcu@intel.com>
+
+Index: pycurl-7.19.3/setup.py
===================================================================
---- pycurl-7.19.0.2.orig/setup.py 2013-10-08 15:28:53.000000000 +0300
-+++ pycurl-7.19.0.2/setup.py 2013-11-04 13:46:47.928292585 +0200
-@@ -101,7 +101,7 @@
- # support one or the other of these curl-config options, so gracefully
- # tolerate failure of either, but not both.
+--- pycurl-7.19.3.orig/setup.py 2014-01-10 08:04:40.000000000 +0200
++++ pycurl-7.19.3/setup.py 2014-02-04 15:09:08.411552887 +0200
+@@ -211,7 +211,7 @@
+ # If neither --libs nor --static-libs work, fail.
optbuf = ""
+ errtext = ''
- for option in ["--libs", "--static-libs"]:
+ for option in ["--libs"]:
- p = subprocess.Popen("'%s' %s" % (CURL_CONFIG, option), shell=True,
- stdout=subprocess.PIPE)
- (stdout, stderr) = p.communicate()
+ p = subprocess.Popen((CURL_CONFIG, option),
+ stdout=subprocess.PIPE, stderr=subprocess.PIPE)
+ stdout, stderr = p.communicate()