aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python-pexpect_4.0.1.bb
diff options
context:
space:
mode:
authorAlexander Kanavin <alexander.kanavin@linux.intel.com>2015-12-16 17:51:24 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-12-27 11:26:56 +0000
commitaa3d92b81b584ef285cbae1939c22394eb6d22ca (patch)
treee151e1d11f4aff599c250c8525c4cc8db88c9257 /meta/recipes-devtools/python/python-pexpect_4.0.1.bb
parent1b09449dedfa2421c662b1d6f2104c235443e566 (diff)
downloadopenembedded-core-contrib-aa3d92b81b584ef285cbae1939c22394eb6d22ca.tar.gz
pytnon-pexpect: update to 4.0.1
LICENSE checksum changed to an additional copyright attribution line Signed-off-by: Alexander Kanavin <alexander.kanavin@linux.intel.com>
Diffstat (limited to 'meta/recipes-devtools/python/python-pexpect_4.0.1.bb')
-rw-r--r--meta/recipes-devtools/python/python-pexpect_4.0.1.bb25
1 files changed, 25 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python-pexpect_4.0.1.bb b/meta/recipes-devtools/python/python-pexpect_4.0.1.bb
new file mode 100644
index 0000000000..7f142a3854
--- /dev/null
+++ b/meta/recipes-devtools/python/python-pexpect_4.0.1.bb
@@ -0,0 +1,25 @@
+SUMMARY = "A Pure Python Expect like Module for Python"
+HOMEPAGE = "http://pexpect.readthedocs.org/"
+SECTION = "devel/python"
+LICENSE = "ISC"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=66c2378a96b307d56bfb3a9e58edafa8"
+
+SRC_URI = "https://pypi.python.org/packages/source/p/pexpect/pexpect-${PV}.tar.gz"
+SRC_URI[md5sum] = "056df81e6ca7081f1015b4b147b977b7"
+SRC_URI[sha256sum] = "232795ebcaaf2e120396dbbaa3a129eda51757eeaae1911558f4ef8ee414fc6c"
+
+UPSTREAM_CHECK_URI = "https://pypi.python.org/pypi/pexpect"
+
+S = "${WORKDIR}/pexpect-${PV}"
+
+inherit distutils
+
+RDEPENDS_${PN} = "\
+ python-core \
+ python-io \
+ python-terminal \
+ python-resource \
+ python-fcntl \
+"
+
+BBCLASSEXTEND = "nativesdk"