aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python-numpy/armeb/numpyconfig.h
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@intel.com>2014-01-14 15:19:29 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-01-14 16:21:37 +0000
commit9bf355cceaec6ebacdcbcc35f9713ff73e1c85da (patch)
treea14dcdcdeaa97426deb8cf7c57d26b5c3facad7d /meta/recipes-devtools/python/python-numpy/armeb/numpyconfig.h
parent6b0c3e9955292d2ea13c6871c686824cd04150f1 (diff)
downloadopenembedded-core-contrib-9bf355cceaec6ebacdcbcc35f9713ff73e1c85da.tar.gz
python-numpy: add (from meta-oe)
python-numpy is needed for Piglit. This recipe is taken directly from meta-oe. Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/python/python-numpy/armeb/numpyconfig.h')
-rw-r--r--meta/recipes-devtools/python/python-numpy/armeb/numpyconfig.h17
1 files changed, 17 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python-numpy/armeb/numpyconfig.h b/meta/recipes-devtools/python/python-numpy/armeb/numpyconfig.h
new file mode 100644
index 0000000000..c4bf6547f0
--- /dev/null
+++ b/meta/recipes-devtools/python/python-numpy/armeb/numpyconfig.h
@@ -0,0 +1,17 @@
+/* cat ./src.linux-i686-2.5/numpy/core/include/numpy/numpyconfig.h */
+/*
+ * * This file is generated by numpy/core/setup.pyc. DO NOT EDIT
+ * */
+#define NPY_SIZEOF_SHORT 2
+#define NPY_SIZEOF_INT 4
+#define NPY_SIZEOF_LONG 4
+#define NPY_SIZEOF_FLOAT 4
+#define NPY_SIZEOF_DOUBLE 8
+#define NPY_SIZEOF_LONGDOUBLE 12
+#define NPY_SIZEOF_PY_INTPTR_T 4
+#define NPY_NO_SMP 0
+
+#define NPY_SIZEOF_LONGLONG 8
+#define NPY_SIZEOF_PY_LONG_LONG 8
+/* #define CHAR_BIT 8 */
+