aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python-native_2.7.3.bb
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@intel.com>2013-06-12 17:25:05 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-06-13 17:37:58 +0100
commitd99dac66e3e121e96c4d8a29aee846d4b8f38622 (patch)
tree30b12730a904017ed384eaea2064be2320b827bb /meta/recipes-devtools/python/python-native_2.7.3.bb
parentc4f987239fe78783d732df673a5e592bb05a877d (diff)
downloadopenembedded-core-contrib-d99dac66e3e121e96c4d8a29aee846d4b8f38622.tar.gz
python-native: add nativepython symlink
Add a symlink to the native Python so that scripts can just invoke "nativepython" and get the right one without needing absolute paths (these often end up too long for the #! parser in the kernel as the buffer is 128 bytes long). The name "nativepython" was chosen to match the existing "nativeperl" which serves the same purpose. Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'meta/recipes-devtools/python/python-native_2.7.3.bb')
-rw-r--r--meta/recipes-devtools/python/python-native_2.7.3.bb6
1 files changed, 6 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python-native_2.7.3.bb b/meta/recipes-devtools/python/python-native_2.7.3.bb
index 722d92c096..39d53bb03c 100644
--- a/meta/recipes-devtools/python/python-native_2.7.3.bb
+++ b/meta/recipes-devtools/python/python-native_2.7.3.bb
@@ -48,4 +48,10 @@ do_install() {
for PYTHSCRIPT in `grep -rIl ${bindir}/${PN}/python ${D}${bindir}/${PN}`; do
sed -i -e '1s|^#!.*|#!/usr/bin/env python|' $PYTHSCRIPT
done
+
+ # Add a symlink to the native Python so that scripts can just invoke
+ # "nativepython" and get the right one without needing absolute paths
+ # (these often end up too long for the #! parser in the kernel as the
+ # buffer is 128 bytes long).
+ ln -s python-native/python ${D}${bindir}/nativepython
}