aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python-mako_1.0.6.bb
diff options
context:
space:
mode:
authorJose Lamego <jose.a.lamego@linux.intel.com>2016-11-16 15:22:14 -0600
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-11-23 11:02:32 +0000
commit7828fd75ca8bf3480141237ba300d01a81634b91 (patch)
treef44415d51eb91bdb26e08fb80db223b1755dc331 /meta/recipes-devtools/python/python-mako_1.0.6.bb
parente5d8b008d5a1385097a2ac642b8daf8940a899a6 (diff)
downloadopenembedded-core-contrib-7828fd75ca8bf3480141237ba300d01a81634b91.tar.gz
python*-mako: upgrade to 1.0.6
Both python-mako and python3-mako need to be upgraded to latest upstream version. This change was tested using qemux86 with core-image-sato. Signed-off-by: Jose Lamego <jose.a.lamego@linux.intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta/recipes-devtools/python/python-mako_1.0.6.bb')
-rw-r--r--meta/recipes-devtools/python/python-mako_1.0.6.bb17
1 files changed, 17 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python-mako_1.0.6.bb b/meta/recipes-devtools/python/python-mako_1.0.6.bb
new file mode 100644
index 0000000000..230044e1a2
--- /dev/null
+++ b/meta/recipes-devtools/python/python-mako_1.0.6.bb
@@ -0,0 +1,17 @@
+require python-mako.inc
+
+inherit setuptools
+
+RDEPENDS_${PN} = "python-threading \
+ python-netclient \
+ python-html \
+"
+RDEPENDS_${PN}_class-native = ""
+
+BBCLASSEXTEND = "native nativesdk"
+
+# The same utility is packaged in python3-mako, so it would conflict
+do_install_append() {
+ rm -f ${D}${bindir}/mako-render
+ rmdir ${D}${bindir}
+}