summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python-extras.inc
diff options
context:
space:
mode:
authorRobert Yang <liezhi.yang@windriver.com>2018-07-27 14:59:25 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-07-30 12:44:35 +0100
commit76fbee59374d282c9d7e62db95c0968745411777 (patch)
tree1b6632e8e8eeae5cac71841b4b87c844ec92cafa /meta/recipes-devtools/python/python-extras.inc
parentac134ce9be6e15c7e6b49c14173903855df14318 (diff)
downloadopenembedded-core-contrib-76fbee59374d282c9d7e62db95c0968745411777.tar.gz
python3-extras: add it for python3-testtools
- The python3-testtools RDEPENDS on it. - The original one is python-extras_1.0.0.bb which is from meta-openstack layer, I divided it into python-extras.inc and python3-extras_1.0.0.bb, and extended to nativesdk. (From OE-Core rev: 0176e798364689774bed4ac4bd0e345c32ea3078) Signed-off-by: Robert Yang <liezhi.yang@windriver.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/python/python-extras.inc')
-rw-r--r--meta/recipes-devtools/python/python-extras.inc12
1 files changed, 12 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python-extras.inc b/meta/recipes-devtools/python/python-extras.inc
new file mode 100644
index 0000000000..b5e11b711a
--- /dev/null
+++ b/meta/recipes-devtools/python/python-extras.inc
@@ -0,0 +1,12 @@
+SUMMARY = "Useful extra bits for Python - things that should be in the standard library"
+HOMEPAGE = "https://pypi.python.org/pypi/extras/"
+SECTION = "devel/python"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=6d108f338b2f68fe48ac366c4650bd8b"
+
+inherit pypi
+
+SRC_URI[md5sum] = "3a63ad60cf8f0186c9e3a02f55ec5b14"
+SRC_URI[sha256sum] = "132e36de10b9c91d5d4cc620160a476e0468a88f16c9431817a6729611a81b4e"
+
+BBCLASSEXTEND = "nativesdk"