summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python-numpy
diff options
context:
space:
mode:
authorAlejandro Enedino Hernandez Samaniego <alejandro.enedino.hernandez-samaniego@xilinx.com>2019-05-17 16:49:12 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2019-05-21 12:56:16 +0100
commita625899c4de4f8ec030ade09686f0c7c0e624a50 (patch)
treeb77b9db5c92ec2f4e42cbfb9e771d2049c83d363 /meta/recipes-devtools/python-numpy
parenta9f62ea2c380375c749a28405708bfdb7754f51f (diff)
downloadopenembedded-core-contrib-a625899c4de4f8ec030ade09686f0c7c0e624a50.tar.gz
python-numpy: Avoid installing copy of f2py script
Both python-numpy and python3-numpy try to install the file: ${D}/${bindir}/f2py which causes an error during do_rootfs since the package manager complains about that. The numpy packages create basically copies of f2py script with the following names: f2py (on both) f2py2 (on python 2) f2py2.7 (on python 2) f2py3 (on python 3) f2py3.7 (on python 3) Remove the copy of f2py from python-numpy in favor of using the one from python3 to avoid installation issues at do_rootfs(). Signed-off-by: Alejandro Enedino Hernandez Samaniego <alejandr@xilinx.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/python-numpy')
-rw-r--r--meta/recipes-devtools/python-numpy/python-numpy_1.16.3.bb4
1 files changed, 4 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python-numpy/python-numpy_1.16.3.bb b/meta/recipes-devtools/python-numpy/python-numpy_1.16.3.bb
index 50137895ca..a1133dad41 100644
--- a/meta/recipes-devtools/python-numpy/python-numpy_1.16.3.bb
+++ b/meta/recipes-devtools/python-numpy/python-numpy_1.16.3.bb
@@ -4,3 +4,7 @@ require python-numpy.inc
RDEPENDS_${PN}_class-target_append = " \
${PYTHON_PN}-subprocess \
"
+
+do_install_append(){
+ rm ${D}/${bindir}/f2py
+}