aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python-numpy/files
diff options
context:
space:
mode:
authorAlejandro Hernandez <alejandro.hernandez@linux.intel.com>2016-06-08 05:56:11 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-06-12 23:37:00 +0100
commitdd756bb8fdff676dba312e38ebc90c4c89dfe855 (patch)
tree19d2c2c1dc6f802b23515373a2bc8ae9da64f2b2 /meta/recipes-devtools/python-numpy/files
parente2e248919e31029ece26ec0f1383690ce410aa24 (diff)
downloadopenembedded-core-contrib-dd756bb8fdff676dba312e38ebc90c4c89dfe855.tar.gz
python-numpy: Upgrade from 1.10.4 to 1.11.0
Upgrades python-numpy and python3-numpy to 1.11.0, Drops using distutils class, to use setuptools class instead, this fixes a problem where after compilation the package was created as an egg, see YOCTO #8673 Fixes source location for both packages and also adds a new patch to fix the shebang on the f2py script, see YOCTO #9729 Signed-off-by: Alejandro Hernandez <alejandro.hernandez@linux.intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta/recipes-devtools/python-numpy/files')
-rw-r--r--meta/recipes-devtools/python-numpy/files/fix_shebang_f2py.patch29
1 files changed, 29 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python-numpy/files/fix_shebang_f2py.patch b/meta/recipes-devtools/python-numpy/files/fix_shebang_f2py.patch
new file mode 100644
index 0000000000..6c61b09f65
--- /dev/null
+++ b/meta/recipes-devtools/python-numpy/files/fix_shebang_f2py.patch
@@ -0,0 +1,29 @@
+Upstream-Status: Inappropriate [embedded specific]
+
+Avoids using python from the HOSTs native sysroot for f2py,
+uses TARGET env python instead.
+
+Signed-Off-By: Alejandro Hernandez <alejandro.hernandez@linux.intel.com>
+
+Index: numpy-1.11.0/numpy/f2py/setup.py
+===================================================================
+--- numpy-1.11.0.orig/numpy/f2py/setup.py
++++ numpy-1.11.0/numpy/f2py/setup.py
+@@ -37,10 +37,13 @@ def _get_f2py_shebang():
+ should be ``#!python`` rather than ``#!`` followed by the contents of
+ ``sys.executable``.
+ """
+- if set(('bdist_wheel', 'bdist_egg', 'bdist_wininst',
+- 'bdist_rpm')).intersection(sys.argv):
+- return '#!python'
+- return '#!' + sys.executable
++ #if set(('bdist_wheel', 'bdist_egg', 'bdist_wininst',
++ # 'bdist_rpm')).intersection(sys.argv):
++ # return '#!python'
++ #return '#!' + sys.executable
++
++ # On OE, we need to avoid using the HOSTs python-native, we return env python instead
++ return '#!/usr/bin/env python'
+
+
+ def configuration(parent_package='', top_path=None):