summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/pseudo
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@intel.com>2018-11-06 12:24:29 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-11-14 11:14:39 +0000
commite39fec613d52324a4ae415a0c544612a8da4af3b (patch)
tree07fe6b780afa79865e96ba48bde838306a18b1c7 /meta/recipes-devtools/pseudo
parent254c577fae9a649195aaaba4d7a9edb0caaa4941 (diff)
downloadopenembedded-core-contrib-e39fec613d52324a4ae415a0c544612a8da4af3b.tar.gz
pseudo: fix link with new sqlite3
If sqlite3 is built with FTS5 it uses log() from libm, but that linkage is lost if we manually statically link so explicitly link to libm. (From OE-Core rev: b24a67217d82f225e76fbc2dfb70dd8e1a6ea215) Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/pseudo')
-rw-r--r--meta/recipes-devtools/pseudo/files/libm.patch33
-rw-r--r--meta/recipes-devtools/pseudo/pseudo_git.bb1
2 files changed, 34 insertions, 0 deletions
diff --git a/meta/recipes-devtools/pseudo/files/libm.patch b/meta/recipes-devtools/pseudo/files/libm.patch
new file mode 100644
index 0000000000..1a82979313
--- /dev/null
+++ b/meta/recipes-devtools/pseudo/files/libm.patch
@@ -0,0 +1,33 @@
+If sqlite3 is built with FTS5 enabled then it links to libm.so for log(), but if
+we statically link to libsqlite3.a then this linkage is lost.
+
+Work around this by always linking to libm.so.
+
+Upstream-Status: Submitted
+Signed-off-by: Ross Burton <ross.burton@intel.com>
+
+From 4633a8750f0966621d258548fba82bc6aa5aa997 Mon Sep 17 00:00:00 2001
+From: Ross Burton <ross.burton@intel.com>
+Date: Tue, 6 Nov 2018 12:13:17 +0000
+Subject: [PATCH] Makefile: sqlite can need libm
+
+---
+ Makefile.in | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/Makefile.in b/Makefile.in
+index ad6541b..28b5ecb 100644
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -73,7 +73,7 @@ WRAPOBJS=pseudo_wrappers.o
+
+ # needed for anything that links with pseduo_client.o, pretty much
+ CLIENT_LDFLAGS=-ldl -lpthread
+-DB_LDFLAGS=@SQLITE_LDARG@ -lpthread
++DB_LDFLAGS=@SQLITE_LDARG@ -lpthread -lm
+
+ PSEUDO=$(BIN)/pseudo
+ PSEUDODB=$(BIN)/pseudodb
+--
+2.11.0
+
diff --git a/meta/recipes-devtools/pseudo/pseudo_git.bb b/meta/recipes-devtools/pseudo/pseudo_git.bb
index 79e0b6bd21..c9a4ecd2e2 100644
--- a/meta/recipes-devtools/pseudo/pseudo_git.bb
+++ b/meta/recipes-devtools/pseudo/pseudo_git.bb
@@ -2,6 +2,7 @@ require pseudo.inc
SRC_URI = "git://git.yoctoproject.org/pseudo \
file://0001-configure-Prune-PIE-flags.patch \
+ file://libm.patch \
file://fallback-passwd \
file://fallback-group \
file://moreretries.patch \