summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/pseudo/pseudo_git.bb
diff options
context:
space:
mode:
authorRobert Yang <liezhi.yang@windriver.com>2019-12-24 15:21:09 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2019-12-30 08:45:02 +0000
commit319bbf66e03377adf2db7efa93ef578e3460eb38 (patch)
tree51f29b58393f44fe36155be32119cb43d40c74c5 /meta/recipes-devtools/pseudo/pseudo_git.bb
parent197007bac2ad8cba59fa2c68c51bd95e9b66de92 (diff)
downloadopenembedded-core-contrib-319bbf66e03377adf2db7efa93ef578e3460eb38.tar.gz
pseudo: Make realpath() remove trailing slashes
Linux system's realpath() remove trailing slashes, but pseudo's doesn't, need make them identical. E.g., the following code (rel.c) prints '/tmp' with system's realpath, but pseudo's realpath prints '/tmp/': #include <stdio.h> #include <limits.h> #include <stdlib.h> int main() { char out[PATH_MAX]; printf("%s\n", realpath("/tmp/", out)); return 0; } $ bitbake base-passwd -cdevshell # For pseudo env $ gcc rel.c $ ./a.out /tmp/ (but should be /tmp) This patch fixes the problem. Signed-off-by: Robert Yang <liezhi.yang@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/pseudo/pseudo_git.bb')
-rw-r--r--meta/recipes-devtools/pseudo/pseudo_git.bb1
1 files changed, 1 insertions, 0 deletions
diff --git a/meta/recipes-devtools/pseudo/pseudo_git.bb b/meta/recipes-devtools/pseudo/pseudo_git.bb
index 1f2df4a427..7c75293ef1 100644
--- a/meta/recipes-devtools/pseudo/pseudo_git.bb
+++ b/meta/recipes-devtools/pseudo/pseudo_git.bb
@@ -8,6 +8,7 @@ SRC_URI = "git://git.yoctoproject.org/pseudo \
file://toomanyfiles.patch \
file://0001-maketables-wrappers-use-Python-3.patch \
file://0001-Add-statx.patch \
+ file://0001-realpath.c-Remove-trailing-slashes.patch \
"
SRCREV = "060058bb29f70b244e685b3c704eb0641b736f73"