aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/pseudo/pseudo_1.7.5.bb
diff options
context:
space:
mode:
authorPeter Seebach <peter.seebach@windriver.com>2016-02-09 13:57:58 -0600
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-02-10 17:37:36 +0000
commit4bd658f7dae76ae8790fd1dfdd89fa58a456a0a4 (patch)
tree7016bc216660ad9c59457aef982ab63b13f5ff7c /meta/recipes-devtools/pseudo/pseudo_1.7.5.bb
parent8092aa8ff63d9b2016bff138ec05ceb0d0155869 (diff)
downloadopenembedded-core-contrib-4bd658f7dae76ae8790fd1dfdd89fa58a456a0a4.tar.gz
pseudo: uprev to 1.7.5
This uprev adds various improvements with regards to the server spawn logic, and also sorts xattrs to work around a bug in one of the mkfs utilities. Signed-off-by: Peter Seebach <peter.seebach@windriver.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta/recipes-devtools/pseudo/pseudo_1.7.5.bb')
-rw-r--r--meta/recipes-devtools/pseudo/pseudo_1.7.5.bb19
1 files changed, 19 insertions, 0 deletions
diff --git a/meta/recipes-devtools/pseudo/pseudo_1.7.5.bb b/meta/recipes-devtools/pseudo/pseudo_1.7.5.bb
new file mode 100644
index 0000000000..195a50878b
--- /dev/null
+++ b/meta/recipes-devtools/pseudo/pseudo_1.7.5.bb
@@ -0,0 +1,19 @@
+require pseudo.inc
+
+SRC_URI = " \
+ http://downloads.yoctoproject.org/releases/pseudo/${BPN}-${PV}.tar.bz2 \
+ file://fallback-passwd \
+ file://fallback-group \
+"
+
+SRC_URI[md5sum] = "c10209938f03128d0c193f041ff3596d"
+SRC_URI[sha256sum] = "fd89cadec984d3b8202aca465898b1bb4350e0d63ba9aa9ac899f6f50270e688"
+
+PSEUDO_EXTRA_OPTS ?= "--enable-force-async --without-passwd-fallback"
+
+do_install_append_class-native () {
+ install -d ${D}${sysconfdir}
+ # The fallback files should never be modified
+ install -m 444 ${WORKDIR}/fallback-passwd ${D}${sysconfdir}/passwd
+ install -m 444 ${WORKDIR}/fallback-group ${D}${sysconfdir}/group
+}