aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/pseudo/pseudo_1.6.5.bb
diff options
context:
space:
mode:
authorPeter Seebach <peter.seebach@windriver.com>2015-05-04 15:55:49 -0500
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-05-05 22:14:09 +0100
commitf1d086bb7204ad37160e814eaf2504dc867cabff (patch)
tree1e643855ccebed015b639e327b54420ab2f44717 /meta/recipes-devtools/pseudo/pseudo_1.6.5.bb
parenta4d530bcf55f03258078c10a123e2717444e1060 (diff)
downloadopenembedded-core-contrib-f1d086bb7204ad37160e814eaf2504dc867cabff.tar.gz
pseudo 1.6.5: less pointlessly chatty
There was a stupid logic error controlling the diagnostic for a "possible" mismatch involving trailing slashes and whether or not a node was believed to be a directory. Specifically, a diagnostic got printed any time a lookup for a directory *didn't* have a trailing slash, as well as in the (actually intended) case where a non-directory lookup *did*. No other changes, but that one is probably significant. Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/pseudo/pseudo_1.6.5.bb')
-rw-r--r--meta/recipes-devtools/pseudo/pseudo_1.6.5.bb19
1 files changed, 19 insertions, 0 deletions
diff --git a/meta/recipes-devtools/pseudo/pseudo_1.6.5.bb b/meta/recipes-devtools/pseudo/pseudo_1.6.5.bb
new file mode 100644
index 0000000000..2a9dc63d03
--- /dev/null
+++ b/meta/recipes-devtools/pseudo/pseudo_1.6.5.bb
@@ -0,0 +1,19 @@
+require pseudo.inc
+
+SRC_URI = " \
+ http://www.yoctoproject.org/downloads/${BPN}/${BPN}-${PV}.tar.bz2 \
+ file://fallback-passwd \
+ file://fallback-group \
+"
+
+SRC_URI[md5sum] = "a5545ff365e243193c81981df98e870b"
+SRC_URI[sha256sum] = "f5a0af976c958915503f516dd02097ab6a64c98a3c0cb4ceb0ce8b1ef8e38b3c"
+
+PSEUDO_EXTRA_OPTS ?= "--enable-force-async --without-passwd-fallback"
+
+do_install_append_class-native () {
+ install -d ${D}${sysconfdir}
+ # The fallback files should never be modified
+ install -m 444 ${WORKDIR}/fallback-passwd ${D}${sysconfdir}/passwd
+ install -m 444 ${WORKDIR}/fallback-group ${D}${sysconfdir}/group
+}