aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/prelink/prelink_git.bb
diff options
context:
space:
mode:
authorMark Hatle <mark.hatle@windriver.com>2017-08-18 14:12:33 -0500
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-08-19 09:19:12 +0100
commite31c9d32072b9cf62c0e9e55b4d421849d3d489b (patch)
tree01ee0d0c8cbb703d589d78b4b717fe65f5ba350f /meta/recipes-devtools/prelink/prelink_git.bb
parent2f1f3480d344f8521e01f456d2dcd6c4e989ec59 (diff)
downloadopenembedded-core-contrib-e31c9d32072b9cf62c0e9e55b4d421849d3d489b.tar.gz
prelink: Change the behavior to avoid checking USER_CLASSES
The behavior before this change was to check USER_CLASSES and adjust the install script to return either exit 0 (don't do anything) or exit 1 (run on first boot). This enabled a user to include the prelink package without enablign the image-prelink bbclass and get a first boot prelink. Checking USER_CLASSES is not desired, as an image should be able to simply inherit the image-prelink and get the same type of behavior. Modifying the recipe based on the inclusion of a class is a bad idea as it makes this style work more difficult. So we move to a more defined strategy based on exist uses. (That we know of...) If we ae doing a cross install, we want to avoid prelinking. Prelinking during a cross install should be handled by the image-prelink bbclass. If the user desires this to run on the target at first boot they will need to create a custom boot script. [YOCTO #11169] Signed-off-by: Mark Hatle <mark.hatle@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/prelink/prelink_git.bb')
-rw-r--r--meta/recipes-devtools/prelink/prelink_git.bb8
1 files changed, 5 insertions, 3 deletions
diff --git a/meta/recipes-devtools/prelink/prelink_git.bb b/meta/recipes-devtools/prelink/prelink_git.bb
index 4529dbfcfb..b739af0cbd 100644
--- a/meta/recipes-devtools/prelink/prelink_git.bb
+++ b/meta/recipes-devtools/prelink/prelink_git.bb
@@ -150,13 +150,15 @@ do_install_append () {
install -m 0644 ${WORKDIR}/macros.prelink ${D}${sysconfdir}/rpm/macros.prelink
}
-# If we're using image-prelink, we want to skip this on the host side
-# but still do it if the package is installed on the target...
+# If we ae doing a cross install, we want to avoid prelinking.
+# Prelinking during a cross install should be handled by the image-prelink
+# bbclass. If the user desires this to run on the target at first boot
+# they will need to create a custom boot script.
pkg_postinst_prelink() {
#!/bin/sh
if [ "x$D" != "x" ]; then
- ${@bb.utils.contains('USER_CLASSES', 'image-prelink', 'exit 0', 'exit 1', d)}
+ exit 0
fi
prelink -a