aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/pkgconfig/pkgconfig/disable-legacy.patch
diff options
context:
space:
mode:
authorRichard Purdie <rpurdie@linux.intel.com>2010-08-27 15:14:24 +0100
committerRichard Purdie <rpurdie@linux.intel.com>2010-08-27 15:29:45 +0100
commit29d6678fd546377459ef75cf54abeef5b969b5cf (patch)
tree8edd65790e37a00d01c3f203f773fe4b5012db18 /meta/recipes-devtools/pkgconfig/pkgconfig/disable-legacy.patch
parentda49de6885ee1bc424e70bc02f21f6ab920efb55 (diff)
downloadopenembedded-core-contrib-29d6678fd546377459ef75cf54abeef5b969b5cf.tar.gz
Major layout change to the packages directory
Having one monolithic packages directory makes it hard to find things and is generally overwhelming. This commit splits it into several logical sections roughly based on function, recipes.txt gives more information about the classifications used. The opportunity is also used to switch from "packages" to "recipes" as used in OpenEmbedded as the term "packages" can be confusing to people and has many different meanings. Not all recipes have been classified yet, this is just a first pass at separating things out. Some packages are moved to meta-extras as they're no longer actively used or maintained. Signed-off-by: Richard Purdie <rpurdie@linux.intel.com>
Diffstat (limited to 'meta/recipes-devtools/pkgconfig/pkgconfig/disable-legacy.patch')
-rw-r--r--meta/recipes-devtools/pkgconfig/pkgconfig/disable-legacy.patch42
1 files changed, 42 insertions, 0 deletions
diff --git a/meta/recipes-devtools/pkgconfig/pkgconfig/disable-legacy.patch b/meta/recipes-devtools/pkgconfig/pkgconfig/disable-legacy.patch
new file mode 100644
index 0000000000..fea2d3d501
--- /dev/null
+++ b/meta/recipes-devtools/pkgconfig/pkgconfig/disable-legacy.patch
@@ -0,0 +1,42 @@
+On an Fedora host with glib-config installed pkgconfig-native can get into a
+horrible state with recursive calls between pkg-config and glib-config.
+The patch adds a configure time option to disable legacy script support in
+pkgconfig with the --disable-legacy-scripts option, to maintain compatibility
+the default is to leave the scripts enabled.
+
+JL - 22/06/10
+Index: pkg-config-0.23/configure.in
+===================================================================
+--- pkg-config-0.23.orig/configure.in 2008-01-16 22:48:07.000000000 +0000
++++ pkg-config-0.23/configure.in 2010-06-22 13:05:58.951984140 +0100
+@@ -125,6 +125,14 @@
+ AC_CONFIG_SUBDIRS(glib-1.2.10)
+ fi # !native_win32
+
++# legacy *-configure scripts can cause headaches, add option to disable
++AC_ARG_ENABLE(legacy-scripts,
++ [AC_HELP_STRING([--enable-legacy-scripts=@<:@no/yes@:>@],
++ [Whether pkg-config will try and use legacy scripts such as glib-config and gnome-config @<:@default=yes@:>@])],
++ [],
++ [enable_legacy=yes])
++AM_CONDITIONAL([LEGACY_SCRIPTS], [test x$enable_legacy = xyes])
++
+ AC_FUNC_ALLOCA
+
+ AC_CHECK_FUNCS(setresuid setreuid,break)
+Index: pkg-config-0.23/parse.c
+===================================================================
+--- pkg-config-0.23.orig/parse.c 2008-01-16 20:42:49.000000000 +0000
++++ pkg-config-0.23/parse.c 2010-06-22 13:09:10.410129471 +0100
+@@ -1195,6 +1195,11 @@
+ * messages.
+ */
+ return NULL;
++#elif defined(LEGACY_SCRIPTS)
++ /* There are scenarios where we might not want to use these legacy
++ * scripts even if they are available.
++ */
++ return NULL;
+ #else
+
+ Package *pkg;