aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/perl
diff options
context:
space:
mode:
authorRobert Yang <liezhi.yang@windriver.com>2014-08-27 22:40:05 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-08-28 15:11:10 +0100
commit83dec26849a120d0f1de64e63025354fa7108491 (patch)
treee9b7577f6b8d7571c2e028cf601fd4f95966a4cf /meta/recipes-devtools/perl
parent347551fadfadeb7bde5948bbeca2a4f13ecaca41 (diff)
downloadopenembedded-core-contrib-83dec26849a120d0f1de64e63025354fa7108491.tar.gz
perl-native: fixed bad interpreter error
We may get the error on some hosts when build in deeper dir: /bin/sh: /path/to/tmp/sysroots/i686-linux/usr/bin/perl-native/pod2man: /path/to/tmp/sysroots/i686-li: bad interpreter: No such file or directory Note the "i686-li", it should be "i686-linux", but is truncated by the host. We can use "/usr/bin/env nativeperl" as we have done in cpan.bbclass for other recipe's perl script to fix the problem. Signed-off-by: Robert Yang <liezhi.yang@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/perl')
-rw-r--r--meta/recipes-devtools/perl/perl-native_5.20.0.bb5
1 files changed, 5 insertions, 0 deletions
diff --git a/meta/recipes-devtools/perl/perl-native_5.20.0.bb b/meta/recipes-devtools/perl/perl-native_5.20.0.bb
index 4364d41b35..069696ae0c 100644
--- a/meta/recipes-devtools/perl/perl-native_5.20.0.bb
+++ b/meta/recipes-devtools/perl/perl-native_5.20.0.bb
@@ -105,6 +105,11 @@ do_install () {
create_wrapper ${D}${bindir}/perl PERL5LIB='$PERL5LIB:${STAGING_LIBDIR}/perl/${PV}:${STAGING_LIBDIR}/perl/'
create_wrapper ${D}${bindir}/perl${PV} PERL5LIB='$PERL5LIB:${STAGING_LIBDIR}/perl/${PV}:${STAGING_LIBDIR}/perl/'
+
+ # Use /usr/bin/env nativeperl for the perl script.
+ for f in `grep -Il '#! *${bindir}/perl' ${D}/${bindir}/*`; do
+ sed -i -e 's|${bindir}/perl|/usr/bin/env nativeperl|' $f
+ done
}
SYSROOT_PREPROCESS_FUNCS += "perl_sysroot_create_wrapper"