aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/perl
diff options
context:
space:
mode:
authorRobert Yang <liezhi.yang@windriver.com>2015-06-22 20:11:58 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-07-01 15:39:58 +0100
commitf4248c6a69b8ce1086f348e7f16e114775828a10 (patch)
tree9e953fc3f87040599441020ba1b5dc1c0013cce6 /meta/recipes-devtools/perl
parentd61804d923e07db592f446955f5bc29690241000 (diff)
downloadopenembedded-core-contrib-f4248c6a69b8ce1086f348e7f16e114775828a10.tar.gz
perl: odbm.t: fix the path of dbmt_common.pl
It should be ../t/lib/dbmt_common.pl. Fixed: Can't locate ../../t/lib/dbmt_common.pl in @INC (From OE-Core rev: d261f4254b049276c086bc05adb068deb331e1d5) Signed-off-by: Robert Yang <liezhi.yang@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/perl')
-rw-r--r--meta/recipes-devtools/perl/perl/ext-ODBM_File-t-odbm.t-fix-the-path-of-dbmt_common.p.patch31
-rw-r--r--meta/recipes-devtools/perl/perl_5.22.0.bb1
2 files changed, 32 insertions, 0 deletions
diff --git a/meta/recipes-devtools/perl/perl/ext-ODBM_File-t-odbm.t-fix-the-path-of-dbmt_common.p.patch b/meta/recipes-devtools/perl/perl/ext-ODBM_File-t-odbm.t-fix-the-path-of-dbmt_common.p.patch
new file mode 100644
index 0000000000..6b05b877fb
--- /dev/null
+++ b/meta/recipes-devtools/perl/perl/ext-ODBM_File-t-odbm.t-fix-the-path-of-dbmt_common.p.patch
@@ -0,0 +1,31 @@
+From b842e1de7798a1f7df770bb3f185ad3356e490e6 Mon Sep 17 00:00:00 2001
+From: Robert Yang <liezhi.yang@windriver.com>
+Date: Mon, 22 Jun 2015 20:06:56 -0700
+Subject: [PATCH] ext/ODBM_File/t/odbm.t: fix the path of dbmt_common.pl
+
+It should be lib/dbmt_common.pl when run by run-ptest.
+
+Fixed:
+Can't locate ../../t/lib/dbmt_common.pl in @INC
+
+Signed-off-by: Robert Yang <liezhi.yang@windriver.com>
+---
+ ext/ODBM_File/t/odbm.t | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/ext/ODBM_File/t/odbm.t b/ext/ODBM_File/t/odbm.t
+index 079b9f1..250b991 100644
+--- a/ext/ODBM_File/t/odbm.t
++++ b/ext/ODBM_File/t/odbm.t
+@@ -2,7 +2,7 @@
+
+ our $DBM_Class = 'ODBM_File';
+
+-require '../../t/lib/dbmt_common.pl';
++require 'lib/dbmt_common.pl';
+
+ if ($^O eq 'hpux') {
+ print <<EOM;
+--
+1.7.9.5
+
diff --git a/meta/recipes-devtools/perl/perl_5.22.0.bb b/meta/recipes-devtools/perl/perl_5.22.0.bb
index 7c7041475f..1aa97373e0 100644
--- a/meta/recipes-devtools/perl/perl_5.22.0.bb
+++ b/meta/recipes-devtools/perl/perl_5.22.0.bb
@@ -60,6 +60,7 @@ SRC_URI += " \
file://make_ext.pl-fix-regenerate-makefile-failed-while-cc-.patch \
file://t-run-switches.t-perl5-perl.patch \
file://ext-ODBM_File-hints-linux.pl-link-libgdbm_compat.patch \
+ file://ext-ODBM_File-t-odbm.t-fix-the-path-of-dbmt_common.p.patch \
"
# Fix test case issues