aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/perl
diff options
context:
space:
mode:
authorRobert Yang <liezhi.yang@windriver.com>2015-06-19 01:26:09 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-07-01 15:39:58 +0100
commitae4e9de7c4626517e76d3bf8fc251af9807b3661 (patch)
tree86307aaa15748c4f3a4b1fbe1d7a32c61d29713f /meta/recipes-devtools/perl
parent3020570504826da0583986af84ca7ff2d936c22a (diff)
downloadopenembedded-core-contrib-ae4e9de7c4626517e76d3bf8fc251af9807b3661.tar.gz
perl: fix test case switches.t
We call it perl rather than perl5 in oe-core. (From OE-Core rev: 13518a25cbad122be4d3f15dbe87cc5a53ef5b1d) Signed-off-by: Robert Yang <liezhi.yang@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/perl')
-rw-r--r--meta/recipes-devtools/perl/perl/t-run-switches.t-perl5-perl.patch30
-rw-r--r--meta/recipes-devtools/perl/perl_5.22.0.bb1
2 files changed, 31 insertions, 0 deletions
diff --git a/meta/recipes-devtools/perl/perl/t-run-switches.t-perl5-perl.patch b/meta/recipes-devtools/perl/perl/t-run-switches.t-perl5-perl.patch
new file mode 100644
index 0000000000..03fdf4ab98
--- /dev/null
+++ b/meta/recipes-devtools/perl/perl/t-run-switches.t-perl5-perl.patch
@@ -0,0 +1,30 @@
+From 1561549ea36e37cc25706f094a195de4928f4211 Mon Sep 17 00:00:00 2001
+From: Robert Yang <liezhi.yang@windriver.com>
+Date: Fri, 19 Jun 2015 01:23:46 -0700
+Subject: [PATCH] t/run/switches.t: perl5 -> perl
+
+We call it perl rather than perl5 in oe.
+
+Upstream-Status: Inappropriate [oe specific]
+
+Signed-off-by: Robert Yang <liezhi.yang@windriver.com>
+---
+ t/run/switches.t | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/t/run/switches.t b/t/run/switches.t
+index 78915e0..e9e4b45 100644
+--- a/t/run/switches.t
++++ b/t/run/switches.t
+@@ -269,7 +269,7 @@ is runperl(stderr => 1, prog => '#!perl -M'),
+ '-V generates 20+ lines' );
+
+ like( runperl( switches => ['-V'] ),
+- qr/\ASummary of my perl5 .*configuration:/,
++ qr/\ASummary of my perl .*configuration:/,
+ '-V looks okay' );
+
+ # lookup a known config var
+--
+1.7.9.5
+
diff --git a/meta/recipes-devtools/perl/perl_5.22.0.bb b/meta/recipes-devtools/perl/perl_5.22.0.bb
index e749078a0f..da3dba6ebb 100644
--- a/meta/recipes-devtools/perl/perl_5.22.0.bb
+++ b/meta/recipes-devtools/perl/perl_5.22.0.bb
@@ -58,6 +58,7 @@ SRC_URI += " \
file://config.sh-64-le \
file://config.sh-64-be \
file://make_ext.pl-fix-regenerate-makefile-failed-while-cc-.patch \
+ file://t-run-switches.t-perl5-perl.patch \
"
# Fix test case issues