aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/perl
diff options
context:
space:
mode:
authorMike Crowe <mcrowe@brightsign.biz>2016-02-05 18:04:18 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-02-10 16:06:24 +0000
commit961d898310ff51824f5dbd37bf768a74c9a3871d (patch)
tree57e53383944ac1e86374193e708ebc9e62891a3d /meta/recipes-devtools/perl
parentecb9c34bbc8bb4c86b02fde88d09985d4f2d61c6 (diff)
downloadopenembedded-core-contrib-961d898310ff51824f5dbd37bf768a74c9a3871d.tar.gz
perl: Explicitly set EXTRA_OEMAKE as required
This recipe currently relies on EXTRA_OEMAKE having been set to "-e MAKEFLAGS=" in bitbake.conf to operate. It is necessary to make this explicit so that the default in bitbake.conf can be changed. (From OE-Core rev: cdd3b32183afe2b4eadbb576f34f19355614b1ac) Signed-off-by: Mike Crowe <mac@mcrowe.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/perl')
-rw-r--r--meta/recipes-devtools/perl/perl-native_5.22.1.bb2
-rw-r--r--meta/recipes-devtools/perl/perl_5.22.1.bb2
2 files changed, 4 insertions, 0 deletions
diff --git a/meta/recipes-devtools/perl/perl-native_5.22.1.bb b/meta/recipes-devtools/perl/perl-native_5.22.1.bb
index 9ffb24825b..ed8222f24c 100644
--- a/meta/recipes-devtools/perl/perl-native_5.22.1.bb
+++ b/meta/recipes-devtools/perl/perl-native_5.22.1.bb
@@ -1,5 +1,7 @@
require perl.inc
+EXTRA_OEMAKE = "-e MAKEFLAGS="
+
SRC_URI += "\
file://Configure-multilib.patch \
file://perl-configpm-switch.patch \
diff --git a/meta/recipes-devtools/perl/perl_5.22.1.bb b/meta/recipes-devtools/perl/perl_5.22.1.bb
index 54594b1dfc..bf8b3b60be 100644
--- a/meta/recipes-devtools/perl/perl_5.22.1.bb
+++ b/meta/recipes-devtools/perl/perl_5.22.1.bb
@@ -87,6 +87,8 @@ export PERLHOSTLIB = "${STAGING_LIBDIR_NATIVE}/perl-native/perl/${PV}/"
export PERL_LIB = "${STAGING_LIBDIR_NATIVE}/perl-native/perl/${PV}/"
export PERL_ARCHLIB = "${STAGING_LIBDIR_NATIVE}/perl-native/perl/${PV}/"
+EXTRA_OEMAKE = "-e MAKEFLAGS="
+
# LDFLAGS for shared libraries
export LDDLFLAGS = "${LDFLAGS} -shared"