aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/perl
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2016-02-02 13:50:47 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-02-04 23:39:00 +0000
commit6ab50017e18cbb5eeeee2df9075fdfa54d05489f (patch)
treec19e07a3e7c63c881339bc625cdca5b6714cb295 /meta/recipes-devtools/perl
parente8860f77a2099d41cab3bdd290c801596bcfbba4 (diff)
downloadopenembedded-core-contrib-6ab50017e18cbb5eeeee2df9075fdfa54d05489f.tar.gz
busybox/gtk/perl/base-passwd: Ensure data is correctly expanded
Where variables are used in python, we need to ensure they are expanded. This happens to work at the moment but likely will not happen in future and isn't good code practise. Its mostly an issue around key values, since bitbake has already performed key expansion when these functions are executed. (From OE-Core rev: 6d1142b56948c048111c4f78d9909c1846ab225b) Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/perl')
-rw-r--r--meta/recipes-devtools/perl/perl_5.22.1.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta/recipes-devtools/perl/perl_5.22.1.bb b/meta/recipes-devtools/perl/perl_5.22.1.bb
index 705852c01c..54594b1dfc 100644
--- a/meta/recipes-devtools/perl/perl_5.22.1.bb
+++ b/meta/recipes-devtools/perl/perl_5.22.1.bb
@@ -349,7 +349,7 @@ python populate_packages_prepend () {
# modules. Don't attempt to use the result of do_split_packages() as some
# modules are manually split (eg. perl-module-unicore).
packages = filter(lambda p: 'perl-module-' in p, d.getVar('PACKAGES', True).split())
- d.setVar("RRECOMMENDS_${PN}-modules", ' '.join(packages))
+ d.setVar(d.expand("RRECOMMENDS_${PN}-modules"), ' '.join(packages))
}
PACKAGES_DYNAMIC += "^perl-module-.*"