aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/perl
diff options
context:
space:
mode:
authorGuojian Zhou <guojian.zhou@windriver.com>2016-05-16 16:53:38 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-05-17 14:43:29 +0100
commit3fec661466a9d0e897c78705bb3464689b0cd623 (patch)
tree6dd5be9609eb034cc1b59334becff1dc68fdbe95 /meta/recipes-devtools/perl
parent9e48d198ed77a16f4760fb9668459de331773c6c (diff)
downloadopenembedded-core-contrib-3fec661466a9d0e897c78705bb3464689b0cd623.tar.gz
perl: use PACKAGESPLITFUNCS instead of populate_packages_prepend
This is cleaner and leads to more accurate profiles. (From OE-Core rev: 76727170def4fe540bed28f79fca09037a1b3fe4) Signed-off-by: Guojian Zhou <guojian.zhou@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/perl')
-rw-r--r--meta/recipes-devtools/perl/perl_5.22.1.bb4
1 files changed, 3 insertions, 1 deletions
diff --git a/meta/recipes-devtools/perl/perl_5.22.1.bb b/meta/recipes-devtools/perl/perl_5.22.1.bb
index bf8b3b60be..f955e6ff4b 100644
--- a/meta/recipes-devtools/perl/perl_5.22.1.bb
+++ b/meta/recipes-devtools/perl/perl_5.22.1.bb
@@ -340,7 +340,9 @@ FILES_perl-module-unicore += "${libdir}/perl/${PV}/unicore"
ALLOW_EMPTY_perl-modules = "1"
PACKAGES_append = " perl-modules "
-python populate_packages_prepend () {
+PACKAGESPLITFUNCS_prepend = "split_perl_packages "
+
+python split_perl_packages () {
libdir = d.expand('${libdir}/perl/${PV}')
do_split_packages(d, libdir, 'auto/([^.]*)/[^/]*\.(so|ld|ix|al)', 'perl-module-%s', 'perl module %s', recursive=True, match_path=True, prepend=False)
do_split_packages(d, libdir, 'Module/([^\/]*)\.pm', 'perl-module-%s', 'perl module %s', recursive=True, allow_dirs=False, match_path=True, prepend=False)