summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/perl/perl_5.30.0.bb
diff options
context:
space:
mode:
authorJoshua Watt <jpewhacker@gmail.com>2019-06-21 08:30:30 -0500
committerRichard Purdie <richard.purdie@linuxfoundation.org>2019-06-21 16:18:32 +0100
commit9297cabb0aca8212d3cc74f8d26e43abc02ded87 (patch)
tree81e00b3b835858b0ac3f15098d58d0480ab187aa /meta/recipes-devtools/perl/perl_5.30.0.bb
parentec8a2b310d5f0b42f60898a5c6d239949842b34c (diff)
downloadopenembedded-core-contrib-9297cabb0aca8212d3cc74f8d26e43abc02ded87.tar.gz
perl: Reproducible build fixes
Applies two patches that are required to improve the reproducibility of builds. Signed-off-by: Joshua Watt <JPEWhacker@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/perl/perl_5.30.0.bb')
-rw-r--r--meta/recipes-devtools/perl/perl_5.30.0.bb5
1 files changed, 5 insertions, 0 deletions
diff --git a/meta/recipes-devtools/perl/perl_5.30.0.bb b/meta/recipes-devtools/perl/perl_5.30.0.bb
index b18a6b6913..e3664290e3 100644
--- a/meta/recipes-devtools/perl/perl_5.30.0.bb
+++ b/meta/recipes-devtools/perl/perl_5.30.0.bb
@@ -19,6 +19,8 @@ SRC_URI = "https://www.cpan.org/src/5.0/perl-${PV}.tar.gz;name=perl \
file://perl-dynloader.patch \
file://0001-configure_path.sh-do-not-hardcode-prefix-lib-as-libr.patch \
file://fix-setgroup.patch \
+ file://0001-enc2xs-Add-environment-variable-to-suppress-comments.patch \
+ file://0002-Constant-Fix-up-shebang.patch \
"
SRC_URI_append_class-native = " \
file://perl-configpm-switch.patch \
@@ -37,6 +39,9 @@ DEPENDS += "db gdbm zlib virtual/crypt"
PERL_LIB_VER = "${@'.'.join(d.getVar('PV').split('.')[0:2])}.0"
+# Don't generate comments in enc2xs output files. They are not reproducible
+export ENC2XS_NO_COMMENTS = "1"
+
do_unpack_append() {
bb.build.exec_func('do_copy_perlcross', d)
}