aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/perl/perl_5.24.1.bb
diff options
context:
space:
mode:
authorAndre McCurdy <armccurdy@gmail.com>2017-03-06 20:58:47 -0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-03-07 21:46:52 +0000
commita75ccaea77c8aad8d46e87e8ed4af2e2e0ad5327 (patch)
tree5ecfb3a947c6a0d9be4d96e18c0a6873a2b8962c /meta/recipes-devtools/perl/perl_5.24.1.bb
parent839d6f124c2761194c868cf5597e1aa96571e1ca (diff)
downloadopenembedded-core-contrib-a75ccaea77c8aad8d46e87e8ed4af2e2e0ad5327.tar.gz
meta: start to ignore the largefile distro feature
The largefile distro feature has been enabled by default in oe-core for a long time and, more recently, also in poky-tiny. Building without the largefile distro feature receives little or no testing. Many packages now enable LFS without exposing a configure option, so there should be very little expectation that disabling the distro feature will result in a distro which globally disables LFS. Respecting the distro feature adds a maintenance over-head and may be the source of configurations oddities (e.g. dbus-native currently builds with LFS disabled for no clear reason - fixed by this commit). Ignore the largefile distro feature more widely, as a first step towards deprecating and eventually removing it. Signed-off-by: Andre McCurdy <armccurdy@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/perl/perl_5.24.1.bb')
-rw-r--r--meta/recipes-devtools/perl/perl_5.24.1.bb13
1 files changed, 0 insertions, 13 deletions
diff --git a/meta/recipes-devtools/perl/perl_5.24.1.bb b/meta/recipes-devtools/perl/perl_5.24.1.bb
index 147e151d74..cf7a8e1218 100644
--- a/meta/recipes-devtools/perl/perl_5.24.1.bb
+++ b/meta/recipes-devtools/perl/perl_5.24.1.bb
@@ -99,17 +99,6 @@ LDFLAGS_append = " -fstack-protector"
# We're almost Debian, aren't we?
CFLAGS += "-DDEBIAN"
-do_nolargefile() {
- sed -i -e "s,\(uselargefiles=\)'define',\1'undef',g" \
- -e "s,\(d_readdir64_r=\)'define',\1'undef',g" \
- -e "s,\(readdir64_r_proto=\)'\w+',\1'0',g" \
- -e "/ccflags_uselargefiles/d" \
- -e "s/-Duselargefiles//" \
- -e "s/-D_FILE_OFFSET_BITS=64//" \
- -e "s/-D_LARGEFILE_SOURCE//" \
- ${S}/Cross/config.sh-${TARGET_ARCH}-${TARGET_OS}
-}
-
do_configure() {
# Make hostperl in build directory be the native perl
ln -sf ${HOSTPERL} hostperl
@@ -182,8 +171,6 @@ do_configure() {
config.sh-${TARGET_ARCH}-${TARGET_OS}
fi
- ${@bb.utils.contains('DISTRO_FEATURES', 'largefile', '', 'do_nolargefile', d)}
-
# Update some paths in the configuration
sed -i -e 's,@ARCH@-thread-multi,,g' \
-e 's,@ARCH@,${TARGET_ARCH}-${TARGET_OS},g' \