aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/perl/perl_5.24.1.bb
diff options
context:
space:
mode:
authorsweeaun <swee.aun.khor@intel.com>2017-07-05 16:56:37 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-07-08 13:33:59 +0100
commit4a50250edb48510fa6382b2700a39a74847d287b (patch)
tree46b865265802cf0b7524a178b7ede5c6286addc7 /meta/recipes-devtools/perl/perl_5.24.1.bb
parent28cd7c5a5cd0567439146eaa30c45301e76b71b6 (diff)
downloadopenembedded-core-contrib-4a50250edb48510fa6382b2700a39a74847d287b.tar.gz
perl: Support musl-x32 build
Existing musl fixups in perl recipe doesn't cover linux-muslx32. This is fixed to support musl-x32 build. Signed-off-by: sweeaun <swee.aun.khor@intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta/recipes-devtools/perl/perl_5.24.1.bb')
-rw-r--r--meta/recipes-devtools/perl/perl_5.24.1.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta/recipes-devtools/perl/perl_5.24.1.bb b/meta/recipes-devtools/perl/perl_5.24.1.bb
index b0ceb84912..95d9694005 100644
--- a/meta/recipes-devtools/perl/perl_5.24.1.bb
+++ b/meta/recipes-devtools/perl/perl_5.24.1.bb
@@ -125,7 +125,7 @@ do_configure() {
done
# Fixups for musl
- if [ "${TARGET_OS}" = "linux-musl" -o "${TARGET_OS}" = "linux-musleabi" ]; then
+ if [ "${TARGET_OS}" = "linux-musl" -o "${TARGET_OS}" = "linux-musleabi" -o "${TARGET_OS}" = "linux-muslx32" ]; then
sed -i -e "s,\(d_libm_lib_version=\)'define',\1'undef',g" \
-e "s,\(d_stdio_ptr_lval=\)'define',\1'undef',g" \
-e "s,\(d_stdio_ptr_lval_sets_cnt=\)'define',\1'undef',g" \