aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/perl/perl_5.14.2.bb
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2012-09-28 14:15:30 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-09-28 15:14:46 +0100
commit31ff70794ecc431431476f81c8934fff25383613 (patch)
treec78ae0a6887f9ce3b8d260576c84ac523f113185 /meta/recipes-devtools/perl/perl_5.14.2.bb
parentbbcc66dc2d69821adb5b39b3642c368fb74ad4d7 (diff)
downloadopenembedded-core-contrib-31ff70794ecc431431476f81c8934fff25383613.tar.gz
perl: Fix substitution madness
We're going around in circles trying to fix the sed expressions and making one case work and others not work. This patch fixes the base configuration file so we have non-overlapping substitutions. I've tried to significantly clean up various problems that were occurring once and for all. This will hopefully resolve all the issues people have been seeing with incorrect perl paths. Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/perl/perl_5.14.2.bb')
-rw-r--r--meta/recipes-devtools/perl/perl_5.14.2.bb12
1 files changed, 6 insertions, 6 deletions
diff --git a/meta/recipes-devtools/perl/perl_5.14.2.bb b/meta/recipes-devtools/perl/perl_5.14.2.bb
index 00098553dd..09b2acb191 100644
--- a/meta/recipes-devtools/perl/perl_5.14.2.bb
+++ b/meta/recipes-devtools/perl/perl_5.14.2.bb
@@ -146,14 +146,14 @@ do_configure() {
${@base_contains('DISTRO_FEATURES', 'largefile', '', 'do_nolargefile', d)}
# Update some paths in the configuration
- sed -i -e 's,@DESTDIR@,${prefix},g' \
- -e 's,@ARCH@-thread-multi,,g' \
+ sed -i -e 's,@ARCH@-thread-multi,,g' \
-e 's,@ARCH@,${TARGET_ARCH}-${TARGET_OS},g' \
-e 's,@STAGINGDIR@,${STAGING_DIR_HOST},g' \
- -e "s%\([ \"^\',=]\+\)/usr/include\([ \"^\',=]\+\)%\1${STAGING_INCDIR}\2%g" \
- -e "s%\([ \"^\',=]\+\)/usr/lib/\([ \"^\',=]\+\)%\1${libdir}/\2%g" \
- -e "s%\([ \"^\',=]\+\)/usr/\([ \"^\',=]\+\)%\1${exec_prefix}/\2%g" \
- -e "s%/perl5%/perl%g" \
+ -e "s,@INCLUDEDIR@,${STAGING_INCDIR},g" \
+ -e "s,@LIBDIR@,${libdir},g" \
+ -e "s,@BASELIBDIR@,${base_libdir},g" \
+ -e "s,@EXECPREFIX@,${exec_prefix},g" \
+ -e 's,@USRBIN@,${bindir},g' \
config.sh-${TARGET_ARCH}-${TARGET_OS}
case "${TARGET_ARCH}" in